aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/patches/002-disable_rfkill.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/mac80211/patches/002-disable_rfkill.patch')
-rw-r--r--package/mac80211/patches/002-disable_rfkill.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/package/mac80211/patches/002-disable_rfkill.patch b/package/mac80211/patches/002-disable_rfkill.patch
new file mode 100644
index 000000000..685006bd5
--- /dev/null
+++ b/package/mac80211/patches/002-disable_rfkill.patch
@@ -0,0 +1,38 @@
+--- a/config.mk
++++ b/config.mk
+@@ -78,7 +78,7 @@ endif # build check
+ endif # kernel Makefile check
+
+ # These both are needed by 802.11 and bluetooth so enable
+- export CONFIG_COMPAT_RFKILL=y
++# export CONFIG_COMPAT_RFKILL=y
+
+ ifeq ($(CONFIG_MAC80211),y)
+ $(error "ERROR: you have MAC80211 compiled into the kernel, CONFIG_MAC80211=y, as such you cannot replace its mac80211 driver. You need this set to CONFIG_MAC80211=m. If you are using Fedora upgrade your kernel as later version should this set as modular. For further information on Fedora see https://bugzilla.redhat.com/show_bug.cgi?id=470143. If you are using your own kernel recompile it and make mac80211 modular")
+@@ -690,10 +690,10 @@ endif #CONFIG_COMPAT_KERNEL_2_6_27
+ # We need the backported rfkill module on kernel < 2.6.31.
+ # In more recent kernel versions use the in kernel rfkill module.
+ ifdef CONFIG_COMPAT_KERNEL_2_6_31
+-export CONFIG_RFKILL_BACKPORT=m
++#export CONFIG_RFKILL_BACKPORT=m
+ ifdef CONFIG_LEDS_TRIGGERS
+-export CONFIG_RFKILL_BACKPORT_LEDS=y
++#export CONFIG_RFKILL_BACKPORT_LEDS=y
+ endif #CONFIG_LEDS_TRIGGERS
+-export CONFIG_RFKILL_BACKPORT_INPUT=y
++#export CONFIG_RFKILL_BACKPORT_INPUT=y
+ endif #CONFIG_COMPAT_KERNEL_2_6_31
+
+--- a/include/linux/rfkill.h
++++ b/include/linux/rfkill.h
+@@ -3,6 +3,10 @@
+
+ #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,31))
+
++#undef CONFIG_RFKILL
++#undef CONFIG_RFKILL_LEDS
++#undef CONFIG_RFKILL_MODULE
++
+ #include_next <linux/rfkill.h>
+
+ #else