aboutsummaryrefslogtreecommitdiffstats
path: root/package/ltq-kpi2udp/patches
diff options
context:
space:
mode:
Diffstat (limited to 'package/ltq-kpi2udp/patches')
-rw-r--r--package/ltq-kpi2udp/patches/100-configure.patch11
-rw-r--r--package/ltq-kpi2udp/patches/110-ifx_udp_redirect.patch29
2 files changed, 40 insertions, 0 deletions
diff --git a/package/ltq-kpi2udp/patches/100-configure.patch b/package/ltq-kpi2udp/patches/100-configure.patch
new file mode 100644
index 000000000..8f6704e9e
--- /dev/null
+++ b/package/ltq-kpi2udp/patches/100-configure.patch
@@ -0,0 +1,11 @@
+--- a/configure.in
++++ b/configure.in
+@@ -113,7 +113,7 @@
+ AC_ARG_ENABLE(kernelbuild,
+ AS_HELP_STRING(--enable-kernelbuild=x,Set the target kernel build path),
+ [
+- if test -r $enableval/include/linux/autoconf.h; then
++ if test -r $enableval/include/generated/autoconf.h; then
+ AC_SUBST([KERNEL_BUILD_PATH],[$enableval])
+ else
+ AC_MSG_ERROR([The kernel build directory is not valid or not configured!])
diff --git a/package/ltq-kpi2udp/patches/110-ifx_udp_redirect.patch b/package/ltq-kpi2udp/patches/110-ifx_udp_redirect.patch
new file mode 100644
index 000000000..abb3d353a
--- /dev/null
+++ b/package/ltq-kpi2udp/patches/110-ifx_udp_redirect.patch
@@ -0,0 +1,29 @@
+--- a/ifx_udp_redirect.c
++++ b/ifx_udp_redirect.c
+@@ -256,7 +256,7 @@
+ {
+ if (redtab.channels[i].in_use == IFX_TRUE)
+ {
+- if (redtab.channels[i].sk->sk_lock.owner != 0)
++ if (redtab.channels[i].sk->sk_lock.owned != 0)
+ return IFX_TRUE;
+ }
+ }
+@@ -545,7 +545,7 @@
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,0))
+ if (sk->num != htons(sport))
+ #else
+- if (((struct inet_sock *)sk)->num != htons(sport))
++ if (((struct inet_sock *)sk)->inet_num != htons(sport))
+ #endif
+ {
+ return CALL_MK_SESSION_ERR;
+@@ -628,7 +628,7 @@
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,0))
+ if((vsock != NULL)&&(vsk != NULL)&&(vsk->num > 0))
+ #else
+- if((vsock != NULL)&&(vsk != NULL)&&(((struct inet_sock *)vsk)->num > 0))
++ if((vsock != NULL)&&(vsk != NULL)&&(((struct inet_sock *)vsk)->inet_num > 0))
+ #endif
+ {
+ /*printk("[KPI2UDP] releasing vsock...%p, ops %p\n", vsock, vsock->ops);*/