aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/001-depends.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/modules/001-depends.mk')
-rw-r--r--package/kernel/modules/001-depends.mk37
1 files changed, 37 insertions, 0 deletions
diff --git a/package/kernel/modules/001-depends.mk b/package/kernel/modules/001-depends.mk
new file mode 100644
index 000000000..6c493018d
--- /dev/null
+++ b/package/kernel/modules/001-depends.mk
@@ -0,0 +1,37 @@
+#
+# Copyright (C) 2010-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define AddDepends/crc16
+ DEPENDS+= +kmod-lib-crc16 $(1)
+endef
+
+define AddDepends/hid
+ DEPENDS+= +kmod-hid $(1)
+endef
+
+define AddDepends/input
+ DEPENDS+= +kmod-input-core $(1)
+endef
+
+
+define AddDepends/nls
+ DEPENDS+= +kmod-nls-base $(foreach cp,$(1),+kmod-nls-$(cp))
+endef
+
+
+define SetDepends/rfkill
+ DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini)
+endef
+
+define AddDepends/rfkill
+ DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill $(1)
+endef
+
+
+define AddDepends/rtc
+ DEPENDS+= @RTC_SUPPORT
+endef