aboutsummaryrefslogtreecommitdiffstats
path: root/package/hotplug2/patches/110-static_worker.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/hotplug2/patches/110-static_worker.patch')
-rw-r--r--package/hotplug2/patches/110-static_worker.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/hotplug2/patches/110-static_worker.patch b/package/hotplug2/patches/110-static_worker.patch
new file mode 100644
index 000000000..3a5181f74
--- /dev/null
+++ b/package/hotplug2/patches/110-static_worker.patch
@@ -0,0 +1,20 @@
+--- a/common.mak
++++ b/common.mak
+@@ -1,7 +1,7 @@
+ # vim:set sw=8 nosta:
+
+ COPTS=-Os -Wall -g
+-LDFLAGS=-g -ldl
++LDFLAGS=-g
+
+ CFLAGS=$(COPTS)
+ FPIC=-fPIC
+--- a/Makefile
++++ b/Makefile
+@@ -40,5 +40,6 @@ ifdef STATIC_WORKER
+ CFLAGS += -DSTATIC_WORKER=1
+ else
+ CFLAGS += $(FPIC)
++ LDFLAGS += -ldl
+ endif
+