aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/imagebuilder/files/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index b0d0698ac..4d0f1fe11 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -134,6 +134,14 @@ package_install: FORCE
copy_files: FORCE
@echo
@echo Copying extra files
+ @( cd $(USER_FILES); find -type f ) | \
+ ( cd $(TARGET_DIR); while :; do \
+ read FILE; \
+ [ -z "$$FILE" ] && break; \
+ [ -L "$$FILE" ] || continue; \
+ echo "Removing symlink $(TARGET_DIR)/$$FILE"; \
+ rm -f "$$FILE"; \
+ done; )
$(CP) $(USER_FILES)/* $(TARGET_DIR)/
package_postinst: FORCE