aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Config.in7
-rw-r--r--include/image.mk2
2 files changed, 8 insertions, 1 deletions
diff --git a/Config.in b/Config.in
index bd4f63ea4..19c8edfb9 100644
--- a/Config.in
+++ b/Config.in
@@ -124,6 +124,13 @@ menu "Target Images"
help
Allows you to change the maximum number of inodes in the root filesystem
+ config TARGET_ROOTFS_RESERVED_PCT
+ int "Percentage of reserved blocks in root filesystem"
+ depends TARGET_ROOTFS_EXT4FS
+ default 5
+ help
+ Allows you to change the percentage of reserved blocks in the root filesystem
+
endmenu
menu "Global build settings"
diff --git a/include/image.mk b/include/image.mk
index 1977fc84c..f0d2ee664 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -124,7 +124,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_EXT4FS),)
define Image/mkfs/ext4
# generate an ext2 fs
- $(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -N $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext4
+ $(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -N $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext4 -m $(CONFIG_TARGET_ROOTFS_RESERVED_PCT)
# convert it to ext4
$(STAGING_DIR_HOST)/bin/tune2fs -O extents,uninit_bg,dir_index $(KDIR)/root.ext4
# fix it up