aboutsummaryrefslogtreecommitdiffstats
path: root/tools/ppl
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
commit5c105d9f3fd086aff195d3849dcf847d6b0bd927 (patch)
tree1229a11f725bfa58aa7c57a76898553bb5f6654a /tools/ppl
downloadopenwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.tar.gz
openwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.zip
branch Attitude Adjustment
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/ppl')
-rw-r--r--tools/ppl/Makefile35
-rw-r--r--tools/ppl/patches/001-gmp_5_fix.patch38
-rw-r--r--tools/ppl/patches/002-replace-pkglib_DATA.patch75
3 files changed, 148 insertions, 0 deletions
diff --git a/tools/ppl/Makefile b/tools/ppl/Makefile
new file mode 100644
index 000000000..46c966d82
--- /dev/null
+++ b/tools/ppl/Makefile
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ppl
+PKG_VERSION:=0.10.2
+
+PKG_SOURCE_URL:=ftp://gcc.gnu.org/pub/gcc/infrastructure
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=e7dd265afdeaea81f7e87a72b182d875
+
+HOST_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared
+
+define Host/Configure
+ (cd $(HOST_BUILD_DIR)/$(3); \
+ $(HOST_CONFIGURE_CMD) \
+ $(HOST_CONFIGURE_VARS) \
+ $(HOST_CONFIGURE_ARGS); \
+ )
+endef
+
+
+$(eval $(call HostBuild))
diff --git a/tools/ppl/patches/001-gmp_5_fix.patch b/tools/ppl/patches/001-gmp_5_fix.patch
new file mode 100644
index 000000000..bd7fad3f4
--- /dev/null
+++ b/tools/ppl/patches/001-gmp_5_fix.patch
@@ -0,0 +1,38 @@
+From: Roberto Bagnara <bagnara@cs.unipr.it>
+Date: Sat, 9 Jan 2010 15:32:08 +0000 (+0100)
+Subject: Added support for GMP 5.0.
+X-Git-Url: http://www.cs.unipr.it/git/gitweb.cgi?p=ppl%2Fppl.git;a=commitdiff_plain;h=9c19bc2b318a35016e0189f9552c98910be37f53
+
+Added support for GMP 5.0.
+---
+
+diff --git a/m4/ac_check_gmp.m4 b/m4/ac_check_gmp.m4
+index 60cecdc..15acb18 100644
+--- a/m4/ac_check_gmp.m4
++++ b/m4/ac_check_gmp.m4
+@@ -71,6 +71,10 @@ AC_RUN_IFELSE([AC_LANG_SOURCE([[
+ #GMP version 4.1.3 or higher is required
+ #endif
+
++#ifndef BITS_PER_MP_LIMB
++#define BITS_PER_MP_LIMB GMP_LIMB_BITS
++#endif
++
+ int
+ main() {
+ std::string header_version;
+@@ -97,11 +101,11 @@ main() {
+ return 1;
+ }
+
+- if (sizeof(mp_limb_t)*CHAR_BIT != GMP_LIMB_BITS
+- || GMP_LIMB_BITS != mp_bits_per_limb) {
++ if (sizeof(mp_limb_t)*CHAR_BIT != BITS_PER_MP_LIMB
++ || BITS_PER_MP_LIMB != mp_bits_per_limb) {
+ std::cerr
+ << "GMP header (gmp.h) and library (ligmp.*) bits-per-limb mismatch:\n"
+- << "header gives " << __GMP_BITS_PER_MP_LIMB << ";\n"
++ << "header gives " << BITS_PER_MP_LIMB << ";\n"
+ << "library gives " << mp_bits_per_limb << ".\n"
+ << "This probably means you are on a bi-arch system and\n"
+ << "you are compiling with the wrong header or linking with\n"
diff --git a/tools/ppl/patches/002-replace-pkglib_DATA.patch b/tools/ppl/patches/002-replace-pkglib_DATA.patch
new file mode 100644
index 000000000..c3dfe076c
--- /dev/null
+++ b/tools/ppl/patches/002-replace-pkglib_DATA.patch
@@ -0,0 +1,75 @@
+--- a/interfaces/Prolog/Ciao/Makefile.am
++++ b/interfaces/Prolog/Ciao/Makefile.am
+@@ -165,7 +165,7 @@ $(NO_UNDEFINED_FLAG) \
+ -module \
+ -avoid-version
+
+-pkglib_DATA = ppl_ciao.po
++pkgdata_DATA = ppl_ciao.po
+
+ ppl_ciao.pl: $(interface_generator_dependencies)
+ $(M4) --prefix-builtin -I../.. -I$(srcdir)/.. -I$(srcdir)/../.. \
+--- a/interfaces/Prolog/GNU/Makefile.am
++++ b/interfaces/Prolog/GNU/Makefile.am
+@@ -164,7 +164,7 @@ ppl_gprolog.pl: $(interface_generator_de
+ $(M4) --prefix-builtin -I../.. -I$(srcdir)/.. -I$(srcdir)/../.. \
+ $(srcdir)/ppl_interface_generator_gprolog_pl.m4 > $@
+
+-pkglib_DATA = ppl_gprolog.pl
++pkgdata_DATA = ppl_gprolog.pl
+
+ bin_PROGRAMS = ppl_gprolog
+
+--- a/interfaces/Prolog/SICStus/Makefile.am
++++ b/interfaces/Prolog/SICStus/Makefile.am
+@@ -68,7 +68,7 @@ ppl_sicstus_SOURCES =
+
+ if ENABLE_SHARED
+
+-pkglib_DATA = ppl_sicstus.pl ppl_sicstus.s.o
++pkgdata_DATA = ppl_sicstus.pl ppl_sicstus.s.o
+
+ ppl_sicstus.so: ppl_sicstus.pl $(top_builddir)/src/libppl.la $(WATCHDOG_LIBRARY) libppl_sicstus.la
+ $(LIBTOOL) --mode=link --tag=CXX \
+@@ -86,7 +86,7 @@ install-data-local: ppl_sicstus.so
+
+ else !ENABLE_SHARED
+
+-pkglib_DATA = ppl_sicstus.pl
++pkgdata_DATA = ppl_sicstus.pl
+
+ endif !ENABLE_SHARED
+
+--- a/interfaces/Prolog/SWI/Makefile.am
++++ b/interfaces/Prolog/SWI/Makefile.am
+@@ -184,7 +184,7 @@ $(NO_UNDEFINED_FLAG) \
+ bin_PROGRAMS = ppl_pl
+ ppl_pl_SOURCES = ppl_pl.cc
+
+-pkglib_DATA = ppl_swiprolog.pl
++pkgdata_DATA = ppl_swiprolog.pl
+
+ CLPQ_TESTS_NONSTRICT = \
+ ack.clpq \
+--- a/interfaces/Prolog/XSB/Makefile.am
++++ b/interfaces/Prolog/XSB/Makefile.am
+@@ -183,7 +183,7 @@ $(NO_UNDEFINED_FLAG) \
+ -module \
+ -avoid-version
+
+-pkglib_DATA = ppl_xsb.xwam
++pkgdata_DATA = ppl_xsb.xwam
+
+ ppl_xsb.xwam: ppl_xsb.H ppl_xsb.cc libppl_xsb.la
+ cp -f ppl_xsb.cc ppl_xsb.c
+--- a/interfaces/Prolog/YAP/Makefile.am
++++ b/interfaces/Prolog/YAP/Makefile.am
+@@ -173,7 +173,7 @@ $(NO_UNDEFINED_FLAG) \
+ -module \
+ -avoid-version
+
+-pkglib_DATA = ppl_yap.pl
++pkgdata_DATA = ppl_yap.pl
+
+ CLPQ_TESTS_NONSTRICT = \
+ ack.clpq \