aboutsummaryrefslogtreecommitdiffstats
path: root/tools/pkg-config
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
commit5c105d9f3fd086aff195d3849dcf847d6b0bd927 (patch)
tree1229a11f725bfa58aa7c57a76898553bb5f6654a /tools/pkg-config
downloadopenwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.tar.gz
openwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.zip
branch Attitude Adjustment
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/pkg-config')
-rw-r--r--tools/pkg-config/Makefile34
-rwxr-xr-xtools/pkg-config/files/pkg-config3
-rw-r--r--tools/pkg-config/patches/100-disable_compat_cmd.patch22
3 files changed, 59 insertions, 0 deletions
diff --git a/tools/pkg-config/Makefile b/tools/pkg-config/Makefile
new file mode 100644
index 000000000..b72f3ce45
--- /dev/null
+++ b/tools/pkg-config/Makefile
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pkg-config
+PKG_VERSION:=0.25
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://pkgconfig.freedesktop.org/releases/
+PKG_MD5SUM:=a3270bab3f4b69b7dc6dbdacbcae9745
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+
+define Host/Install
+ $(MAKE) -C $(HOST_BUILD_DIR) install \
+ AM_LDFLAGS="$(if $(HOST_STATIC_LINKING),-all-static)"
+ mv $(STAGING_DIR_HOST)/bin/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config.real
+ $(INSTALL_BIN) ./files/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config
+endef
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/pkg-config/files/pkg-config b/tools/pkg-config/files/pkg-config
new file mode 100755
index 000000000..e58b13216
--- /dev/null
+++ b/tools/pkg-config/files/pkg-config
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pkg-config.real $@ --define-variable=prefix=${STAGING_PREFIX} --define-variable=exec_prefix=${STAGING_PREFIX}
diff --git a/tools/pkg-config/patches/100-disable_compat_cmd.patch b/tools/pkg-config/patches/100-disable_compat_cmd.patch
new file mode 100644
index 000000000..990784045
--- /dev/null
+++ b/tools/pkg-config/patches/100-disable_compat_cmd.patch
@@ -0,0 +1,22 @@
+--- a/parse.c
++++ b/parse.c
+@@ -1187,15 +1187,12 @@ try_command (const char *command)
+ Package *
+ get_compat_package (const char *name)
+ {
+-#ifdef G_OS_WIN32
+- /* There has never been any of these legacy *-config scripts on
+- * Windows as far as I know. No use trying to execute them, will
+- * only confuse users to see the "blabla is not recognized as an
+- * internal or external command, operable program or batch file"
+- * messages.
++ /*
++ * We don't need this compatibility stuff on a system
++ * that is free of legacy stuff
+ */
+ return NULL;
+-#else
++#if 0
+
+ Package *pkg;
+