aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/llvm/patches
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
commit5c105d9f3fd086aff195d3849dcf847d6b0bd927 (patch)
tree1229a11f725bfa58aa7c57a76898553bb5f6654a /toolchain/llvm/patches
downloadopenwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.tar.gz
openwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.zip
branch Attitude Adjustment
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/llvm/patches')
-rw-r--r--toolchain/llvm/patches/100-darwin_arch_auto.patch19
-rw-r--r--toolchain/llvm/patches/110-darwin_version_detect.patch16
2 files changed, 35 insertions, 0 deletions
diff --git a/toolchain/llvm/patches/100-darwin_arch_auto.patch b/toolchain/llvm/patches/100-darwin_arch_auto.patch
new file mode 100644
index 000000000..a48e13121
--- /dev/null
+++ b/toolchain/llvm/patches/100-darwin_arch_auto.patch
@@ -0,0 +1,19 @@
+--- a/Makefile.rules
++++ b/Makefile.rules
+@@ -618,16 +618,6 @@ ifdef UNIVERSAL
+
+ # Building universal cannot compute dependencies automatically.
+ DISABLE_AUTO_DEPENDENCIES=1
+-else
+- ifeq ($(TARGET_OS),Darwin)
+- ifeq ($(ARCH),x86_64)
+- TargetCommonOpts = -m64
+- else
+- ifeq ($(ARCH),x86)
+- TargetCommonOpts = -m32
+- endif
+- endif
+- endif
+ endif
+
+ ifeq ($(HOST_OS),SunOS)
diff --git a/toolchain/llvm/patches/110-darwin_version_detect.patch b/toolchain/llvm/patches/110-darwin_version_detect.patch
new file mode 100644
index 000000000..7fd62f93e
--- /dev/null
+++ b/toolchain/llvm/patches/110-darwin_version_detect.patch
@@ -0,0 +1,16 @@
+--- a/Makefile.rules
++++ b/Makefile.rules
+@@ -506,11 +506,13 @@ endif
+ #--------------------------------------------------------------------
+
+ ifeq ($(HOST_OS),Darwin)
++ ifndef DARWIN_VERSION
+ DARWIN_VERSION := `sw_vers -productVersion`
+ # Strip a number like 10.4.7 to 10.4
+ DARWIN_VERSION := $(shell echo $(DARWIN_VERSION)| sed -E 's/(10.[0-9]).*/\1/')
+ # Get "4" out of 10.4 for later pieces in the makefile.
+ DARWIN_MAJVERS := $(shell echo $(DARWIN_VERSION)| sed -E 's/10.([0-9]).*/\1/')
++ endif
+
+ SharedLinkOptions=-Wl,-flat_namespace -Wl,-undefined -Wl,suppress \
+ -dynamiclib