aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/thincan
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
commit5c105d9f3fd086aff195d3849dcf847d6b0bd927 (patch)
tree1229a11f725bfa58aa7c57a76898553bb5f6654a /target/linux/x86/thincan
downloadopenwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.tar.gz
openwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.zip
branch Attitude Adjustment
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/thincan')
-rw-r--r--target/linux/x86/thincan/base-files/etc/init.d/alsa9
-rw-r--r--target/linux/x86/thincan/config-3.315
-rw-r--r--target/linux/x86/thincan/profiles/dbe61.mk25
-rw-r--r--target/linux/x86/thincan/target.mk37
4 files changed, 86 insertions, 0 deletions
diff --git a/target/linux/x86/thincan/base-files/etc/init.d/alsa b/target/linux/x86/thincan/base-files/etc/init.d/alsa
new file mode 100644
index 000000000..94c6965e7
--- /dev/null
+++ b/target/linux/x86/thincan/base-files/etc/init.d/alsa
@@ -0,0 +1,9 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2006 OpenWrt.org
+START=50
+
+start() {
+ amixer set PCM 50% unmute
+ amixer set Headphone 100% unmute
+}
+
diff --git a/target/linux/x86/thincan/config-3.3 b/target/linux/x86/thincan/config-3.3
new file mode 100644
index 000000000..405c65b5f
--- /dev/null
+++ b/target/linux/x86/thincan/config-3.3
@@ -0,0 +1,15 @@
+CONFIG_8139TOO=y
+# CONFIG_8139TOO_8129 is not set
+# CONFIG_8139TOO_PIO is not set
+# CONFIG_8139TOO_TUNE_TWISTER is not set
+# CONFIG_8139_OLD_RX_RESET is not set
+CONFIG_BLK_DEV_NBD=y
+# CONFIG_EMBEDDED is not set
+CONFIG_IP_PNP=y
+# CONFIG_IP_PNP_BOOTP is not set
+CONFIG_IP_PNP_DHCP=y
+# CONFIG_IP_PNP_RARP is not set
+CONFIG_LOCKD=y
+CONFIG_NFS_FS=y
+CONFIG_ROOT_NFS=y
+CONFIG_SUNRPC=y
diff --git a/target/linux/x86/thincan/profiles/dbe61.mk b/target/linux/x86/thincan/profiles/dbe61.mk
new file mode 100644
index 000000000..ee7c251a3
--- /dev/null
+++ b/target/linux/x86/thincan/profiles/dbe61.mk
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DBE61
+ NAME:=DBE61
+endef
+
+define Profile/DBE61/Description
+ Compile OpenWrt for Artec ThinCan DBE61
+
+ ThinCan DBE61 is a thin-client featuring:
+ * AMD Geode LX700
+ * AMD CS5535 companion device
+ * 64MB or 256MB NAND Flash or none
+ * 128MB or 256MB DDR SDRAM
+ * Realtek RTL8139
+
+ http://wiki.thincan.org/DBE61
+endef
+
+$(eval $(call Profile,DBE61))
diff --git a/target/linux/x86/thincan/target.mk b/target/linux/x86/thincan/target.mk
new file mode 100644
index 000000000..cd127a482
--- /dev/null
+++ b/target/linux/x86/thincan/target.mk
@@ -0,0 +1,37 @@
+DEVICE_TYPE:=terminal
+BOARDNAME:=Artec ThinCan
+
+CFLAGS := -O2 -pipe -march=geode -mtune=geode -funit-at-a-time
+
+DEFAULT_PACKAGES:=\
+ base-files \
+ busybox \
+ hotplug2 \
+ libc \
+ libgcc \
+ opkg \
+ uci \
+ udevtrigger \
+ kmod-fs-msdos \
+ kmod-fs-vfat \
+ kmod-fs-ext2 \
+ kmod-fs-ext3 \
+ kmod-fs-ext4 \
+ kmod-usb-core \
+ kmod-usb-ohci \
+ kmod-usb-hid \
+ kmod-usb-storage \
+ kmod-usb2 \
+ kmod-sound-core \
+ kmod-sound-cs5535audio \
+ kmod-crypto-core \
+ kmod-crypto-hw-geode \
+ kmod-crypto-ocf \
+ kmod-crypto-aes
+
+define Target/Description
+ Build firmware images for Artec ThinCan
+
+ Note that NBD, NFS, DHCP and ethernet module are built into kernel
+endef
+