aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/geos
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
commit5c105d9f3fd086aff195d3849dcf847d6b0bd927 (patch)
tree1229a11f725bfa58aa7c57a76898553bb5f6654a /target/linux/x86/geos
downloadopenwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.tar.gz
openwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.zip
branch Attitude Adjustment
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/geos')
-rw-r--r--target/linux/x86/geos/base-files/etc/config/network44
-rw-r--r--target/linux/x86/geos/base-files/etc/config/system30
-rw-r--r--target/linux/x86/geos/base-files/etc/hotplug.d/button/50-reboot13
-rw-r--r--target/linux/x86/geos/config-3.325
-rw-r--r--target/linux/x86/geos/target.mk36
5 files changed, 148 insertions, 0 deletions
diff --git a/target/linux/x86/geos/base-files/etc/config/network b/target/linux/x86/geos/base-files/etc/config/network
new file mode 100644
index 000000000..f49838318
--- /dev/null
+++ b/target/linux/x86/geos/base-files/etc/config/network
@@ -0,0 +1,44 @@
+# Copyright (C) 2011 OpenWrt.org
+
+config interface loopback
+ option ifname lo
+ option proto static
+ option ipaddr 127.0.0.1
+ option netmask 255.0.0.0
+
+config interface lan
+ option ifname "eth0 eth1"
+ option type bridge
+ option proto static
+ option ipaddr 192.168.1.1
+ option netmask 255.255.255.0
+
+config atm-bridge
+ option unit 0
+ option atmdev 0
+ option vpi 0
+ option vci 35
+ option encaps llc
+ option payload bridged
+ option sendsize 2040
+
+config interface wan
+ option proto dhcp
+ option ifname nas0
+ # clone your eth0 address here
+ # option macaddr '00:0A:FA:22:00:80'
+
+# 2nd interface on Geos2
+#config interface wan
+# option proto pppoa
+# option atmdev 1
+# option vpi 8
+# option vci 32
+# option encaps vc
+# option username 'username@myisp.net'
+# option password 'password'
+# option keepalive 3
+# option defaultroute 1
+# option peerdns 1
+# option pppd_options 'kdebug 1 debug noccp'
+
diff --git a/target/linux/x86/geos/base-files/etc/config/system b/target/linux/x86/geos/base-files/etc/config/system
new file mode 100644
index 000000000..988c849ec
--- /dev/null
+++ b/target/linux/x86/geos/base-files/etc/config/system
@@ -0,0 +1,30 @@
+
+config system
+ option hostname OpenWrt
+ option timezone UTC
+
+config timeserver ntp
+ list server 0.openwrt.pool.ntp.org
+ list server 1.openwrt.pool.ntp.org
+ list server 2.openwrt.pool.ntp.org
+ list server 3.openwrt.pool.ntp.org
+
+config led
+ option default 0
+ option name LAN
+ option sysfs 'geos:1'
+ option trigger netdev
+ option mode 'tx rx'
+ option dev 'br-lan'
+
+config led
+ option default 0
+ option name WiFi
+ option sysfs 'geos:2'
+ option trigger 'phy0tpt'
+
+config led
+ option default 0
+ option name Health
+ option sysfs 'geos:3'
+ option trigger 'heartbeat'
diff --git a/target/linux/x86/geos/base-files/etc/hotplug.d/button/50-reboot b/target/linux/x86/geos/base-files/etc/hotplug.d/button/50-reboot
new file mode 100644
index 000000000..bf893c15b
--- /dev/null
+++ b/target/linux/x86/geos/base-files/etc/hotplug.d/button/50-reboot
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+logger -t button -p daemon.info "$BUTTON/$ACTION"
+
+case "$BUTTON/$ACTION" in
+
+reset/released)
+ reboot -f
+ ;;
+
+esac
+
+exit 0
diff --git a/target/linux/x86/geos/config-3.3 b/target/linux/x86/geos/config-3.3
new file mode 100644
index 000000000..d923ef074
--- /dev/null
+++ b/target/linux/x86/geos/config-3.3
@@ -0,0 +1,25 @@
+# CONFIG_ATA_PIIX is not set
+CONFIG_DMI=y
+CONFIG_DMIID=y
+# CONFIG_DMI_SYSFS is not set
+CONFIG_GENERIC_GPIO=y
+CONFIG_GEOS=y
+CONFIG_GPIOLIB=y
+CONFIG_GPIO_SYSFS=y
+# CONFIG_HIGHMEM64G is not set
+CONFIG_HWMON=y
+# CONFIG_ISDN is not set
+# CONFIG_LEDS_CLEVO_MAIL is not set
+# CONFIG_M486 is not set
+# CONFIG_MATH_EMULATION is not set
+CONFIG_MGEODE_LX=y
+CONFIG_NLS=y
+CONFIG_PATA_CS5536=y
+CONFIG_PCI_LABEL=y
+# CONFIG_SCx200 is not set
+CONFIG_THERMAL_HWMON=y
+CONFIG_X86_CMOV=y
+CONFIG_X86_DEBUGCTLMSR=y
+CONFIG_X86_TSC=y
+CONFIG_X86_USE_3DNOW=y
+CONFIG_X86_USE_PPRO_CHECKSUM=y
diff --git a/target/linux/x86/geos/target.mk b/target/linux/x86/geos/target.mk
new file mode 100644
index 000000000..1a65436d6
--- /dev/null
+++ b/target/linux/x86/geos/target.mk
@@ -0,0 +1,36 @@
+BOARDNAME:=Traverse Geos
+FEATURES:=squashfs jffs2 ext4 pci usb gpio
+DEFAULT_PACKAGES += \
+ kmod-crypto-hw-geode kmod-crypto-ocf \
+ kmod-gpio-cs5535-new kmod-gpio-nsc \
+ kmod-wdt-geode kmod-cs5535-clockevt kmod-cs5535-mfgpt \
+ kmod-cs5536 \
+ kmod-hwmon-core kmod-hwmon-lm90 \
+ kmod-8139cp kmod-solos-pci kmod-sched \
+ kmod-i2c-core kmod-i2c-gpio \
+ kmod-i2c-algo-bit kmod-i2c-algo-pca kmod-i2c-algo-pcf \
+ kmod-i2c-scx200-acb \
+ kmod-usb-core kmod-usb2 kmod-usb-ohci \
+ kmod-cfg80211 kmod-mac80211 \
+ kmod-mppe kmod-pppoa kmod-pppol2tp \
+ kmod-ath5k kmod-ath9k \
+ kmod-leds-gpio kmod-input-gpio-keys-polled \
+ kmod-button-hotplug \
+ kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
+ kmod-ledtrig-netdev \
+ kmod-cpu-msr \
+ soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
+ hwclock wpad flashrom tc
+
+CS5535_MASK:=0x0E000048
+
+CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
+ -fno-align-labels -fno-align-loops -pipe -fomit-frame-pointer
+
+define Target/Description
+ Build firmware images for Traverse Geos board
+endef
+
+define KernelPackage/gpio-cs5535-new/install
+ sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-gpio-cs5535-new
+endef