aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/generic/profiles
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
commit5c105d9f3fd086aff195d3849dcf847d6b0bd927 (patch)
tree1229a11f725bfa58aa7c57a76898553bb5f6654a /target/linux/x86/generic/profiles
downloadopenwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.tar.gz
openwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.zip
branch Attitude Adjustment
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/generic/profiles')
-rw-r--r--target/linux/x86/generic/profiles/000-Generic.mk18
-rw-r--r--target/linux/x86/generic/profiles/Soekris45xx.mk16
-rw-r--r--target/linux/x86/generic/profiles/Soekris48xx.mk16
-rw-r--r--target/linux/x86/generic/profiles/Wrap.mk16
4 files changed, 66 insertions, 0 deletions
diff --git a/target/linux/x86/generic/profiles/000-Generic.mk b/target/linux/x86/generic/profiles/000-Generic.mk
new file mode 100644
index 000000000..90f989a91
--- /dev/null
+++ b/target/linux/x86/generic/profiles/000-Generic.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic
+ PACKAGES:=kmod-3c59x kmod-e100 kmod-e1000 kmod-natsemi kmod-ne2k-pci \
+ kmod-pcnet32 kmod-8139too kmod-r8169 kmod-sis900 kmod-tg3 \
+ kmod-via-rhine kmod-via-velocity
+endef
+
+define Profile/Generic/Description
+ Generic Profile
+endef
+$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/generic/profiles/Soekris45xx.mk b/target/linux/x86/generic/profiles/Soekris45xx.mk
new file mode 100644
index 000000000..d1d88c6fc
--- /dev/null
+++ b/target/linux/x86/generic/profiles/Soekris45xx.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Soekris45xx
+ NAME:=Soekris Net45xx
+ PACKAGES:=kmod-natsemi kmod-leds-net48xx kmod-wdt-sc520
+endef
+
+define Profile/Soekris45xx/Description
+ Package set compatible with the Soekris Net45xx. Net4511 and 4521 need PCMCIA Cardbus support. Please add manually.
+endef
+$(eval $(call Profile,Soekris45xx))
diff --git a/target/linux/x86/generic/profiles/Soekris48xx.mk b/target/linux/x86/generic/profiles/Soekris48xx.mk
new file mode 100644
index 000000000..66bafbfe4
--- /dev/null
+++ b/target/linux/x86/generic/profiles/Soekris48xx.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Soekris48xx
+ NAME:=Soekris Net48xx
+ PACKAGES:=kmod-i2c-scx200 kmod-natsemi kmod-leds-net48xx kmod-gpio-scx200 kmod-wdt-scx200 kmod-hwmon-pc87360
+endef
+
+define Profile/Soekris48xx/Description
+ Package set compatible with the Soekris Net4801. Contains I2C/LEDS/GPIO/Sensors support
+endef
+$(eval $(call Profile,Soekris48xx))
diff --git a/target/linux/x86/generic/profiles/Wrap.mk b/target/linux/x86/generic/profiles/Wrap.mk
new file mode 100644
index 000000000..62532ac82
--- /dev/null
+++ b/target/linux/x86/generic/profiles/Wrap.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2006,2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Wrap
+ NAME:=PCEngines WRAP
+ PACKAGES:=kmod-i2c-scx200 kmod-natsemi kmod-leds-wrap kmod-gpio-scx200 kmod-wdt-scx200 kmod-hwmon-pc87360
+endef
+
+define Profile/Wrap/Description
+ Package set compatible with the PCEngines WRAP. Contains I2C/LEDS/GPIO/Sensors support
+endef
+$(eval $(call Profile,Wrap))