aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/alix2
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
commit5c105d9f3fd086aff195d3849dcf847d6b0bd927 (patch)
tree1229a11f725bfa58aa7c57a76898553bb5f6654a /target/linux/x86/alix2
downloadopenwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.tar.gz
openwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.zip
branch Attitude Adjustment
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/alix2')
-rw-r--r--target/linux/x86/alix2/base-files/etc/config/network20
-rw-r--r--target/linux/x86/alix2/base-files/etc/config/system29
-rw-r--r--target/linux/x86/alix2/base-files/etc/hotplug.d/button/50-reboot13
-rw-r--r--target/linux/x86/alix2/config-3.325
-rw-r--r--target/linux/x86/alix2/target.mk34
5 files changed, 121 insertions, 0 deletions
diff --git a/target/linux/x86/alix2/base-files/etc/config/network b/target/linux/x86/alix2/base-files/etc/config/network
new file mode 100644
index 000000000..b46423fe1
--- /dev/null
+++ b/target/linux/x86/alix2/base-files/etc/config/network
@@ -0,0 +1,20 @@
+# Copyright (C) 2011 OpenWrt.org
+
+config interface loopback
+ option ifname lo
+ option proto static
+ option ipaddr 127.0.0.1
+ option netmask 255.0.0.0
+
+# N.B. the labels on the Netgate boxes actually reverse the LAN and WAN
+# port markings.
+config interface lan
+ option ifname eth1
+ option type bridge
+ option proto static
+ option ipaddr 192.168.1.1
+ option netmask 255.255.255.0
+
+config interface wan
+ option ifname eth0
+ option proto dhcp
diff --git a/target/linux/x86/alix2/base-files/etc/config/system b/target/linux/x86/alix2/base-files/etc/config/system
new file mode 100644
index 000000000..473586e29
--- /dev/null
+++ b/target/linux/x86/alix2/base-files/etc/config/system
@@ -0,0 +1,29 @@
+config system
+ option hostname OpenWrt
+ option timezone UTC
+
+config timeserver ntp
+ list server 0.openwrt.pool.ntp.org
+ list server 1.openwrt.pool.ntp.org
+ list server 2.openwrt.pool.ntp.org
+ list server 3.openwrt.pool.ntp.org
+
+config led
+ option default 1
+ option name LAN
+ option sysfs 'alix:1'
+ option trigger netdev
+ option mode 'tx rx'
+ option dev 'br-lan'
+
+config led
+ option default 1
+ option name WiFi
+ option sysfs 'alix:2'
+ option trigger 'phy0tpt'
+
+config led
+ option default 0
+ option name Heartbeat
+ option sysfs 'alix:3'
+ option trigger 'heartbeat'
diff --git a/target/linux/x86/alix2/base-files/etc/hotplug.d/button/50-reboot b/target/linux/x86/alix2/base-files/etc/hotplug.d/button/50-reboot
new file mode 100644
index 000000000..bf893c15b
--- /dev/null
+++ b/target/linux/x86/alix2/base-files/etc/hotplug.d/button/50-reboot
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+logger -t button -p daemon.info "$BUTTON/$ACTION"
+
+case "$BUTTON/$ACTION" in
+
+reset/released)
+ reboot -f
+ ;;
+
+esac
+
+exit 0
diff --git a/target/linux/x86/alix2/config-3.3 b/target/linux/x86/alix2/config-3.3
new file mode 100644
index 000000000..ee7e3a780
--- /dev/null
+++ b/target/linux/x86/alix2/config-3.3
@@ -0,0 +1,25 @@
+CONFIG_ALIX=y
+CONFIG_DEBUG_BUGVERBOSE=y
+CONFIG_DMI=y
+CONFIG_DMIID=y
+# CONFIG_DMI_SYSFS is not set
+CONFIG_GENERIC_GPIO=y
+# CONFIG_GEOS is not set
+CONFIG_GPIOLIB=y
+CONFIG_GPIO_SYSFS=y
+# CONFIG_HIGHMEM64G is not set
+CONFIG_HWMON=y
+# CONFIG_LEDS_CLEVO_MAIL is not set
+# CONFIG_M486 is not set
+# CONFIG_MATH_EMULATION is not set
+CONFIG_MGEODE_LX=y
+CONFIG_NLS=y
+CONFIG_PATA_CS5536=y
+CONFIG_PCI_LABEL=y
+# CONFIG_SCx200 is not set
+CONFIG_THERMAL_HWMON=y
+CONFIG_X86_CMOV=y
+CONFIG_X86_DEBUGCTLMSR=y
+CONFIG_X86_TSC=y
+CONFIG_X86_USE_3DNOW=y
+CONFIG_X86_USE_PPRO_CHECKSUM=y
diff --git a/target/linux/x86/alix2/target.mk b/target/linux/x86/alix2/target.mk
new file mode 100644
index 000000000..33b2e6761
--- /dev/null
+++ b/target/linux/x86/alix2/target.mk
@@ -0,0 +1,34 @@
+BOARDNAME:=PCEngines alix2
+FEATURES:=squashfs jffs2 ext4 pci usb gpio
+DEFAULT_PACKAGES += \
+ kmod-crypto-hw-geode kmod-crypto-ocf kmod-crypto-aes kmod-crypto-cbc \
+ kmod-gpio-cs5535-new kmod-gpio-nsc \
+ kmod-wdt-geode kmod-cs5535-clockevt kmod-cs5535-mfgpt \
+ kmod-cs5536 \
+ kmod-hwmon-core kmod-hwmon-lm90 \
+ kmod-via-rhine \
+ kmod-i2c-core kmod-i2c-gpio \
+ kmod-i2c-algo-bit kmod-i2c-algo-pca kmod-i2c-algo-pcf \
+ kmod-i2c-scx200-acb \
+ kmod-usb-core kmod-usb2 kmod-usb-ohci \
+ kmod-cfg80211 kmod-mac80211 \
+ kmod-mppe kmod-pppoe kmod-pppo2ltp \
+ kmod-ath5k kmod-ath9k \
+ kmod-leds-gpio kmod-input-gpio-keys-polled \
+ kmod-button-hotplug \
+ kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
+ kmod-ledtrig-netdev \
+ kmod-cpu-msr hwclock wpad
+
+CS5535_MASK:=0x0b000042
+
+CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
+ -fno-align-labels -fno-align-loops -pipe -fomit-frame-pointer
+
+define Target/Description
+ Build firmware images for PCEngines alix2 board
+endef
+
+define KernelPackage/gpio-cs5535-new/install
+ sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-gpio-cs5535-new
+endef