aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-19 19:44:56 +0000
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-19 19:44:56 +0000
commit399392c371c0a16e71ce9f7d91d6b1a51919e0d9 (patch)
tree46141dff7b0e4987aeadc3ba22c0793032001eb6 /target/linux/ramips
parentbdc0abae95de2254b31084fa2d28d934e32c0f4c (diff)
downloadopenwrt-399392c371c0a16e71ce9f7d91d6b1a51919e0d9.tar.gz
openwrt-399392c371c0a16e71ce9f7d91d6b1a51919e0d9.zip
AA: ramips: add profile and build image for the TEW-692GR board
Backport of r33849. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33878 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/Makefile18
-rw-r--r--target/linux/ramips/rt3883/profiles/trendnet.mk16
2 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index d8e829883..69787fc2a 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -327,6 +327,19 @@ define BuildFirmware/DIR645/initramfs
$(call BuildFirmware/Generic/initramfs,$(1),$(2),$(call mkcmdline,$(3),$(4),$(5)) $(call mkmtd/$(6),$(mtdlayout_dir645a1)))
endef
+define BuildFirmware/UMedia
+ $(call BuildFirmware/GENERIC_8M,$(1),$(2),$(3),ttyS1,57600,phys)
+ if [ -e "$(call sysupname,$(1),$(2))" ]; then \
+ fix-u-media-header -T 0x46 -B $(4) \
+ -i $(call sysupname,$(1),$(2)) \
+ -o $(call imgname,$(1),$(2))-factory.bin; \
+ fi
+endef
+
+define BuildFirmware/UMedia/initramfs
+ $(call BuildFirmware/GENERIC_8M/initramfs,$(1),$(2),$(3),ttyS1,57600,phys)
+endef
+
define BuildFirmware/W306R_4M
$(call BuildFirmware/w306r,$(1),$(2),$(call mkcmdline,$(3),$(4),$(5)) $(call mkmtd/$(6),$(mtdlayout_4M)),917504,2949120)
endef
@@ -627,10 +640,15 @@ define Image/Build/Profile/RTN56U
$(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,rt-n56u,RT-N56U,ttyS1,57600,phys)
endef
+define Image/Build/Profile/TEW692GR
+ $(call Image/Build/Template/$(fs_squash)/$(1),UMedia,tew-692gr,TEW-692GR,0x026920)
+endef
+
ifeq ($(CONFIG_RALINK_RT3883),y)
define Image/Build/Profile/Default
$(call Image/Build/Profile/DIR645,$(1))
$(call Image/Build/Profile/RTN56U,$(1))
+ $(call Image/Build/Profile/TEW692GR,$(1))
endef
endif
diff --git a/target/linux/ramips/rt3883/profiles/trendnet.mk b/target/linux/ramips/rt3883/profiles/trendnet.mk
new file mode 100644
index 000000000..93bdc5994
--- /dev/null
+++ b/target/linux/ramips/rt3883/profiles/trendnet.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/TEW692GR
+ NAME:=TRENDnet TEW-692GR
+ PACKAGES:=swconfig
+endef
+
+define Profile/TEW692GR/Description
+ Package set compatible with the TRENDnet TEW-692GR board.
+endef
+$(eval $(call Profile,TEW692GR))