aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles/allnet.mk
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
commit5c105d9f3fd086aff195d3849dcf847d6b0bd927 (patch)
tree1229a11f725bfa58aa7c57a76898553bb5f6654a /target/linux/ramips/rt305x/profiles/allnet.mk
downloadopenwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.tar.gz
openwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.zip
branch Attitude Adjustment
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/rt305x/profiles/allnet.mk')
-rw-r--r--target/linux/ramips/rt305x/profiles/allnet.mk41
1 files changed, 41 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/allnet.mk b/target/linux/ramips/rt305x/profiles/allnet.mk
new file mode 100644
index 000000000..fb3e4d411
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/allnet.mk
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ALL02393G
+ NAME:=Allnet ALL0239-3G
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-rt305x-dwc_otg \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/ALL02393G/Description
+ Package set for Allnet ALL0239-3G
+endef
+
+$(eval $(call Profile,ALL02393G))
+
+define Profile/ALL0256N
+ NAME:=Allnet ALL0256N
+ PACKAGES:=rssileds
+endef
+
+define Profile/ALL0256N/Description
+ Package set for Allnet ALL0256N
+endef
+
+$(eval $(call Profile,ALL0256N))
+
+define Profile/ALL5002
+ NAME:=Allnet ALL5002
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/ALL5002/Description
+ Package set for Allnet ALL5002
+endef
+
+$(eval $(call Profile,ALL5002))