aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/pxcab/Makefile
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
commit5c105d9f3fd086aff195d3849dcf847d6b0bd927 (patch)
tree1229a11f725bfa58aa7c57a76898553bb5f6654a /target/linux/pxcab/Makefile
downloadopenwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.tar.gz
openwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.zip
branch Attitude Adjustment
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/pxcab/Makefile')
-rw-r--r--target/linux/pxcab/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/pxcab/Makefile b/target/linux/pxcab/Makefile
new file mode 100644
index 000000000..08ab70ff9
--- /dev/null
+++ b/target/linux/pxcab/Makefile
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=pxcab
+BOARDNAME:=PowerXCell Accelerator Board
+FEATURES:=powerpc64 fpu ramdisk broken
+
+LINUX_VERSION:=2.6.30.10
+
+KERNEL_CC:=
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build zImage for the IBM PowerXCell Accelerator Board
+ (aka mvXCell-8i from MatrixVision or GigaAccel 180 from Fixstars)
+endef
+
+KERNELNAME:="zImage"
+
+DEFAULT_PACKAGES += kmod-tg3
+
+$(eval $(call BuildTarget))