aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/ar9
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
commit5c105d9f3fd086aff195d3849dcf847d6b0bd927 (patch)
tree1229a11f725bfa58aa7c57a76898553bb5f6654a /target/linux/lantiq/ar9
downloadopenwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.tar.gz
openwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.zip
branch Attitude Adjustment
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/ar9')
-rw-r--r--target/linux/lantiq/ar9/config-default40
-rw-r--r--target/linux/lantiq/ar9/profiles/000-generic.mk5
-rw-r--r--target/linux/lantiq/ar9/profiles/001-lantiq.mk10
-rw-r--r--target/linux/lantiq/ar9/profiles/002-netgear.mk11
-rw-r--r--target/linux/lantiq/ar9/profiles/003-buffalo.mk11
-rw-r--r--target/linux/lantiq/ar9/profiles/004-avm.mk7
-rw-r--r--target/linux/lantiq/ar9/profiles/005-zyxel.mk7
-rw-r--r--target/linux/lantiq/ar9/profiles/006-zte.mk7
-rw-r--r--target/linux/lantiq/ar9/target.mk12
9 files changed, 110 insertions, 0 deletions
diff --git a/target/linux/lantiq/ar9/config-default b/target/linux/lantiq/ar9/config-default
new file mode 100644
index 000000000..67b6a4609
--- /dev/null
+++ b/target/linux/lantiq/ar9/config-default
@@ -0,0 +1,40 @@
+CONFIG_ADM6996_PHY=y
+CONFIG_AR8216_PHY=y
+# CONFIG_ATMEL_PWM is not set
+CONFIG_CLKDEV_LOOKUP=y
+CONFIG_FSNOTIFY=y
+CONFIG_HAVE_MACH_CLKDEV=y
+CONFIG_HW_HAS_PCI=y
+CONFIG_INPUT=y
+CONFIG_INPUT_EVDEV=y
+# CONFIG_INPUT_GPIO_BUTTONS is not set
+CONFIG_INPUT_POLLDEV=y
+CONFIG_IRQ_FORCED_THREADING=y
+# CONFIG_ISDN is not set
+CONFIG_LANTIQ_ETOP=y
+# CONFIG_LANTIQ_MACH_ARV is not set
+# CONFIG_LANTIQ_MACH_EASY50712 is not set
+CONFIG_LANTIQ_MACH_FRITZ_AR9=y
+# CONFIG_LANTIQ_MACH_FRITZ_VR9 is not set
+# CONFIG_LANTIQ_MACH_GIGASX76X is not set
+CONFIG_LANTIQ_MACH_NETGEAR=y
+CONFIG_LANTIQ_MACH_WBMR=y
+CONFIG_LANTIQ_MACH_P2601HNFX=y
+CONFIG_LANTIQ_MACH_H201L=y
+# CONFIG_LANTIQ_VRX200 is not set
+CONFIG_MDIO_BOARDINFO=y
+CONFIG_MTD_BLOCK2MTD=y
+CONFIG_PCI=y
+# CONFIG_PCIEPORTBUS is not set
+# CONFIG_PCIE_LANTIQ is not set
+CONFIG_PCI_DOMAINS=y
+CONFIG_PCI_LANTIQ=y
+# CONFIG_PCI_LANTIQ_NONE is not set
+CONFIG_RTL8306_PHY=y
+# CONFIG_SOC_AMAZON_SE is not set
+# CONFIG_SOC_FALCON is not set
+CONFIG_SOC_TYPE_XWAY=y
+CONFIG_SOC_XWAY=y
+# CONFIG_SOC_SVIP is not set
+CONFIG_USB_ARCH_HAS_XHCI=y
+CONFIG_USB_SUPPORT=y
diff --git a/target/linux/lantiq/ar9/profiles/000-generic.mk b/target/linux/lantiq/ar9/profiles/000-generic.mk
new file mode 100644
index 000000000..a8346a746
--- /dev/null
+++ b/target/linux/lantiq/ar9/profiles/000-generic.mk
@@ -0,0 +1,5 @@
+define Profile/Generic
+ NAME:=Generic - all boards
+endef
+
+$(eval $(call Profile,Generic))
diff --git a/target/linux/lantiq/ar9/profiles/001-lantiq.mk b/target/linux/lantiq/ar9/profiles/001-lantiq.mk
new file mode 100644
index 000000000..a1fc2d24b
--- /dev/null
+++ b/target/linux/lantiq/ar9/profiles/001-lantiq.mk
@@ -0,0 +1,10 @@
+define Profile/EASY50812
+ NAME:=EASY50812 - Eval Board
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg
+endef
+
+define Profile/EASY50812/Description
+ Lantiq EASY50812 evalkit
+endef
+
+$(eval $(call Profile,EASY50812))
diff --git a/target/linux/lantiq/ar9/profiles/002-netgear.mk b/target/linux/lantiq/ar9/profiles/002-netgear.mk
new file mode 100644
index 000000000..a3c83bbcd
--- /dev/null
+++ b/target/linux/lantiq/ar9/profiles/002-netgear.mk
@@ -0,0 +1,11 @@
+define Profile/DGN3500B
+ NAME:=DGN3500B Netgear
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg
+endef
+
+define Profile/DGN3500B/Description
+ Netgear DGN3500B
+endef
+
+$(eval $(call Profile,DGN3500B))
+
diff --git a/target/linux/lantiq/ar9/profiles/003-buffalo.mk b/target/linux/lantiq/ar9/profiles/003-buffalo.mk
new file mode 100644
index 000000000..ea2c03e72
--- /dev/null
+++ b/target/linux/lantiq/ar9/profiles/003-buffalo.mk
@@ -0,0 +1,11 @@
+define Profile/WBMR
+ NAME:=WBMR - Buffalo WBMR-HP-G300H
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg kmod-ledtrig-usbdev \
+ kmod-ltq-dsl-firmware-b-ar9
+endef
+
+define Profile/WBMR/Description
+ Package set optimized for the Buffalo WBMR routers
+endef
+
+$(eval $(call Profile,WBMR))
diff --git a/target/linux/lantiq/ar9/profiles/004-avm.mk b/target/linux/lantiq/ar9/profiles/004-avm.mk
new file mode 100644
index 000000000..e424d6aaa
--- /dev/null
+++ b/target/linux/lantiq/ar9/profiles/004-avm.mk
@@ -0,0 +1,7 @@
+define Profile/FRITZ7320
+ NAME:=FRITZ7320 Fritzbox
+ PACKAGES:= kmod-usb-core kmod-usb-ifxhcd kmod-ledtrig-usbdev \
+ kmod-ltq-dsl-firmware-b-ar9 kmod-ath9k wpad-mini
+endef
+
+$(eval $(call Profile,FRITZ7320))
diff --git a/target/linux/lantiq/ar9/profiles/005-zyxel.mk b/target/linux/lantiq/ar9/profiles/005-zyxel.mk
new file mode 100644
index 000000000..8b1384c67
--- /dev/null
+++ b/target/linux/lantiq/ar9/profiles/005-zyxel.mk
@@ -0,0 +1,7 @@
+define Profile/P2601HNFX
+ NAME:=P2601HNFX - ZyXEL P-2601HN-Fx
+ PACKAGES:= kmod-usb-dwc-otg kmod-rt2800-usb wpad-mini \
+ kmod-ltq-dsl-firmware-b-ar9
+endef
+
+$(eval $(call Profile,P2601HNFX))
diff --git a/target/linux/lantiq/ar9/profiles/006-zte.mk b/target/linux/lantiq/ar9/profiles/006-zte.mk
new file mode 100644
index 000000000..c83890fb1
--- /dev/null
+++ b/target/linux/lantiq/ar9/profiles/006-zte.mk
@@ -0,0 +1,7 @@
+define Profile/H201L
+ NAME:=H201L - ZTE ZXV10
+ PACKAGES:= kmod-usb-dwc-otg kmod-ath9k-htc wpad-mini \
+ kmod-ltq-dsl-firmware-b-ar9
+endef
+
+$(eval $(call Profile,H201L))
diff --git a/target/linux/lantiq/ar9/target.mk b/target/linux/lantiq/ar9/target.mk
new file mode 100644
index 000000000..cb57b882c
--- /dev/null
+++ b/target/linux/lantiq/ar9/target.mk
@@ -0,0 +1,12 @@
+ARCH:=mips
+SUBTARGET:=ar9
+BOARDNAME:=AR9
+FEATURES:=squashfs jffs2 atm
+
+DEFAULT_PACKAGES+=kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl kmod-ltq-dsl-ar9 ltq-dsl-app \
+ kmod-input-gpio-keys-polled kmod-ledtrig-netdev kmod-leds-gpio kmod-button-hotplug \
+ swconfig
+
+define Target/Description
+ Lantiq AR9
+endef