aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/generic/profiles
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
commit5c105d9f3fd086aff195d3849dcf847d6b0bd927 (patch)
tree1229a11f725bfa58aa7c57a76898553bb5f6654a /target/linux/ixp4xx/generic/profiles
downloadopenwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.tar.gz
openwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.zip
branch Attitude Adjustment
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ixp4xx/generic/profiles')
-rw-r--r--target/linux/ixp4xx/generic/profiles/100-Default.mk17
-rw-r--r--target/linux/ixp4xx/generic/profiles/105-Atheros-ath5k.mk17
-rw-r--r--target/linux/ixp4xx/generic/profiles/200-NSLU2.mk19
-rw-r--r--target/linux/ixp4xx/generic/profiles/300-NAS100d.mk21
-rw-r--r--target/linux/ixp4xx/generic/profiles/400-DSMG600RevA.mk22
-rw-r--r--target/linux/ixp4xx/generic/profiles/500-USR8200.mk20
6 files changed, 116 insertions, 0 deletions
diff --git a/target/linux/ixp4xx/generic/profiles/100-Default.mk b/target/linux/ixp4xx/generic/profiles/100-Default.mk
new file mode 100644
index 000000000..c881c8001
--- /dev/null
+++ b/target/linux/ixp4xx/generic/profiles/100-Default.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PACKAGES:=kmod-ath5k
+endef
+
+define Profile/Default/Description
+ Default IXP4xx Profile
+endef
+$(eval $(call Profile,Default))
+
diff --git a/target/linux/ixp4xx/generic/profiles/105-Atheros-ath5k.mk b/target/linux/ixp4xx/generic/profiles/105-Atheros-ath5k.mk
new file mode 100644
index 000000000..8f74277c3
--- /dev/null
+++ b/target/linux/ixp4xx/generic/profiles/105-Atheros-ath5k.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros-ath5k
+ NAME:=Atheros WiFi (atk5k)
+ PACKAGES:=kmod-ath5k
+endef
+
+define Profile/Atheros-ath5k/Description
+ Package set compatible with hardware using Atheros WiFi cards
+endef
+$(eval $(call Profile,Atheros-ath5k))
+
diff --git a/target/linux/ixp4xx/generic/profiles/200-NSLU2.mk b/target/linux/ixp4xx/generic/profiles/200-NSLU2.mk
new file mode 100644
index 000000000..523bda4ef
--- /dev/null
+++ b/target/linux/ixp4xx/generic/profiles/200-NSLU2.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NSLU2
+ NAME:=Linksys NSLU2
+ PACKAGES:=-wpad-mini -kmod-ath5k kmod-scsi-core \
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage \
+ kmod-fs-ext2 kmod-fs-ext3
+endef
+
+define Profile/NSLU2/Description
+ Package set optimized for the Linksys NSLU2
+endef
+$(eval $(call Profile,NSLU2))
+
diff --git a/target/linux/ixp4xx/generic/profiles/300-NAS100d.mk b/target/linux/ixp4xx/generic/profiles/300-NAS100d.mk
new file mode 100644
index 000000000..36a544b21
--- /dev/null
+++ b/target/linux/ixp4xx/generic/profiles/300-NAS100d.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NAS100d
+ NAME:=Iomega NAS 100d
+ PACKAGES:=kmod-ath5k \
+ kmod-scsi-core \
+ kmod-ata-core kmod-ata-artop \
+ kmod-usb-core kmod-usb2 kmod-usb-storage \
+ kmod-fs-ext2 kmod-fs-ext3
+endef
+
+define Profile/NAS100d/Description
+ Package set optimized for the Iomega NAS 100d
+endef
+$(eval $(call Profile,NAS100d))
+
diff --git a/target/linux/ixp4xx/generic/profiles/400-DSMG600RevA.mk b/target/linux/ixp4xx/generic/profiles/400-DSMG600RevA.mk
new file mode 100644
index 000000000..6e6afba48
--- /dev/null
+++ b/target/linux/ixp4xx/generic/profiles/400-DSMG600RevA.mk
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DSMG600RevA
+ NAME:=DSM-G600 Rev A
+ PACKAGES:=kmod-via-velocity \
+ kmod-ath5k \
+ kmod-scsi-core \
+ kmod-ata-core kmod-ata-artop \
+ kmod-usb-core kmod-usb-uhci kmod-usb2 kmod-usb-storage \
+ kmod-fs-ext2 kmod-fs-ext3
+endef
+
+define Profile/DSMG600RevA/Description
+ Package set optimized for the DSM-G600 Rev A
+endef
+$(eval $(call Profile,DSMG600RevA))
+
diff --git a/target/linux/ixp4xx/generic/profiles/500-USR8200.mk b/target/linux/ixp4xx/generic/profiles/500-USR8200.mk
new file mode 100644
index 000000000..99cda1399
--- /dev/null
+++ b/target/linux/ixp4xx/generic/profiles/500-USR8200.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/USR8200
+ NAME:=USRobotics USR8200
+ PACKAGES:=-wpad-mini kmod-scsi-core \
+ kmod-usb-core kmod-usb-uhci kmod-usb2 kmod-usb-storage \
+ kmod-fs-ext2 kmod-fs-ext3 \
+ kmod-ieee1394 kmod-ohci1394 kmod-sbp2
+endef
+
+define Profile/USR8200/Description
+ Package set optimized for the USRobotics USR8200
+endef
+$(eval $(call Profile,USR8200))
+