aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/coldfire/image/Makefile
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
commit5c105d9f3fd086aff195d3849dcf847d6b0bd927 (patch)
tree1229a11f725bfa58aa7c57a76898553bb5f6654a /target/linux/coldfire/image/Makefile
downloadopenwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.tar.gz
openwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.zip
branch Attitude Adjustment
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/coldfire/image/Makefile')
-rw-r--r--target/linux/coldfire/image/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/coldfire/image/Makefile b/target/linux/coldfire/image/Makefile
new file mode 100644
index 000000000..94e28b2cb
--- /dev/null
+++ b/target/linux/coldfire/image/Makefile
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2009-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+JFFS2_BLOCKSIZE=128k
+
+define Image/Prepare
+endef
+
+define Image/BuildKernel
+ $(TARGET_CROSS)objcopy -O binary -R .bss -R .note -R .comment \
+ -R .note.gnu.build-id -S $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.bin
+ mkimage -A m68k -O linux -T kernel -a 0x00020000 -e 0x00020000 \
+ -C none -n 'M68K OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/vmlinux.bin $(BIN_DIR)/$(IMG_PREFIX)-uImage
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-128k
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+$(eval $(call BuildImage))