aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/image/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-07 23:25:31 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-07 23:25:31 +0000
commitd19f47f044d1fe318e1008fda6840b4556c61505 (patch)
tree15d195afc0c3a71d560a7d479068d63664533ce6 /target/linux/cns3xxx/image/Makefile
parent09d787a017c6e931f9d9c6ea3bee89fcc9476616 (diff)
downloadopenwrt-d19f47f044d1fe318e1008fda6840b4556c61505.tar.gz
openwrt-d19f47f044d1fe318e1008fda6840b4556c61505.zip
cns3xxx: merge fixes and improvements from trunk
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33652 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/cns3xxx/image/Makefile')
-rw-r--r--target/linux/cns3xxx/image/Makefile19
1 files changed, 15 insertions, 4 deletions
diff --git a/target/linux/cns3xxx/image/Makefile b/target/linux/cns3xxx/image/Makefile
index 271d5ea19..05a0f4f7a 100644
--- a/target/linux/cns3xxx/image/Makefile
+++ b/target/linux/cns3xxx/image/Makefile
@@ -21,21 +21,32 @@ define Image/BuildKernel
cp $(KDIR)/uImage-new $(BIN_DIR)/openwrt-$(BOARD)-uImage
endef
+# Build sysupgrade image
+define BuildFirmware/Generic
+ dd if=$(BIN_DIR)/openwrt-$(BOARD)-uImage of=$(KDIR)/uImage.pad bs=64k conv=sync; \
+ dd if=$(KDIR)/root.$(1) of=$(KDIR)/root.$(1).pad bs=128k conv=sync; \
+ sh $(TOPDIR)/scripts/combined-image.sh \
+ $(KDIR)/uImage.pad \
+ $(KDIR)/root.$(1).pad \
+ $(BIN_DIR)/$(IMG_PREFIX)-$(patsubst jffs2-%,jffs2,$(patsubst squashfs-%,squashfs,$(1)))-sysupgrade.bin
+endef
+
define Image/Build
$(call Image/Build/$(1),$(1))
+ $(call BuildFirmware/Generic,$(1))
endef
define Image/Build/jffs2-64k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=65536 conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=64k conv=sync
endef
define Image/Build/jffs2-128k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=128k conv=sync
endef
define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+ $(call prepare_generic_squashfs,$(KDIR)/root.$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=128k conv=sync
endef
$(eval $(call BuildImage))