aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/profiles
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
commit5c105d9f3fd086aff195d3849dcf847d6b0bd927 (patch)
tree1229a11f725bfa58aa7c57a76898553bb5f6654a /target/linux/brcm47xx/profiles
downloadopenwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.tar.gz
openwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.zip
branch Attitude Adjustment
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm47xx/profiles')
-rw-r--r--target/linux/brcm47xx/profiles/100-Broadcom-b43.mk19
-rw-r--r--target/linux/brcm47xx/profiles/101-Broadcom-wl.mk20
-rw-r--r--target/linux/brcm47xx/profiles/104-Broadcom-ath5k.mk18
-rw-r--r--target/linux/brcm47xx/profiles/105-Broadcom-none.mk17
-rw-r--r--target/linux/brcm47xx/profiles/110-Bcm4705-b43.mk19
-rw-r--r--target/linux/brcm47xx/profiles/115-Bcm4705-none.mk17
-rw-r--r--target/linux/brcm47xx/profiles/PS-1208MFG.mk18
-rw-r--r--target/linux/brcm47xx/profiles/WGT634U.mk17
-rw-r--r--target/linux/brcm47xx/profiles/WL500GPv1-ATH.mk16
-rw-r--r--target/linux/brcm47xx/profiles/WRT350Nv1.mk16
-rw-r--r--target/linux/brcm47xx/profiles/WRTSL54GS.mk17
11 files changed, 194 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/profiles/100-Broadcom-b43.mk b/target/linux/brcm47xx/profiles/100-Broadcom-b43.mk
new file mode 100644
index 000000000..7880ce80f
--- /dev/null
+++ b/target/linux/brcm47xx/profiles/100-Broadcom-b43.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2007-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-b43
+ NAME:=Broadcom BCM43xx WiFi (b43, default)
+ PACKAGES:=kmod-b43 kmod-b43legacy
+endef
+
+define Profile/Broadcom-b43/Description
+ Package set compatible with hardware using Broadcom BCM43xx cards
+ using the MAC80211 b43 and b43legacy drivers and b44 Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-b43))
+
diff --git a/target/linux/brcm47xx/profiles/101-Broadcom-wl.mk b/target/linux/brcm47xx/profiles/101-Broadcom-wl.mk
new file mode 100644
index 000000000..1464b7e15
--- /dev/null
+++ b/target/linux/brcm47xx/profiles/101-Broadcom-wl.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-wl
+ NAME:=Broadcom BCM43xx WiFi (wl, proprietary)
+ PACKAGES:=-wpad-mini kmod-brcm-wl wlc nas
+endef
+
+define Profile/Broadcom-wl/Description
+ Package set compatible with hardware using Broadcom BCM43xx cards
+ using the proprietary broadcom wireless "wl" driver and b44 Ethernet
+ driver.
+endef
+
+$(eval $(call Profile,Broadcom-wl))
+
diff --git a/target/linux/brcm47xx/profiles/104-Broadcom-ath5k.mk b/target/linux/brcm47xx/profiles/104-Broadcom-ath5k.mk
new file mode 100644
index 000000000..32baa089a
--- /dev/null
+++ b/target/linux/brcm47xx/profiles/104-Broadcom-ath5k.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-ath5k
+ NAME:=Atheros WiFi (ath5k)
+ PACKAGES:=kmod-ath5k
+endef
+
+define Profile/Atheros/Description
+ Package set compatible with hardware using Atheros WiFi cards and
+ b44 Ethernet driver.
+endef
+$(eval $(call Profile,Broadcom-ath5k))
+
diff --git a/target/linux/brcm47xx/profiles/105-Broadcom-none.mk b/target/linux/brcm47xx/profiles/105-Broadcom-none.mk
new file mode 100644
index 000000000..04ad25dc6
--- /dev/null
+++ b/target/linux/brcm47xx/profiles/105-Broadcom-none.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-none
+ NAME:=No WiFi
+ PACKAGES:=-wpad-mini
+endef
+
+define Profile/None/Description
+ Package set without WiFi support and b44 Ethernet driver.
+endef
+$(eval $(call Profile,Broadcom-none))
+
diff --git a/target/linux/brcm47xx/profiles/110-Bcm4705-b43.mk b/target/linux/brcm47xx/profiles/110-Bcm4705-b43.mk
new file mode 100644
index 000000000..f5bdaac50
--- /dev/null
+++ b/target/linux/brcm47xx/profiles/110-Bcm4705-b43.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2007-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Bcm4705-b43
+ NAME:=BCM4705/BCM4785, Broadcom BCM43xx WiFi (b43)
+ PACKAGES:=kmod-b43 kmod-b43legacy kmod-tg3 kmod-ssb-gige
+endef
+
+define Profile/Broadcom-b43/Description
+ Package set compatible with hardware using Broadcom BCM43xx cards
+ using the MAC80211 b43 and b43legacy drivers and tg3 Ethernet driver
+endef
+
+$(eval $(call Profile,Bcm4705-b43))
+
diff --git a/target/linux/brcm47xx/profiles/115-Bcm4705-none.mk b/target/linux/brcm47xx/profiles/115-Bcm4705-none.mk
new file mode 100644
index 000000000..5b03f2c5e
--- /dev/null
+++ b/target/linux/brcm47xx/profiles/115-Bcm4705-none.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Bcm4705-none
+ NAME:=BCM4705/BCM4785, no WiFi
+ PACKAGES:=-wpad-mini kmod-tg3 kmod-ssb-gige
+endef
+
+define Profile/None/Description
+ Package set without WiFi support and tg3 Ethernet driver.
+endef
+$(eval $(call Profile,Bcm4705-none))
+
diff --git a/target/linux/brcm47xx/profiles/PS-1208MFG.mk b/target/linux/brcm47xx/profiles/PS-1208MFG.mk
new file mode 100644
index 000000000..5d7388ba1
--- /dev/null
+++ b/target/linux/brcm47xx/profiles/PS-1208MFG.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2007-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Ps1208mfg
+ NAME:=Edimax PS-1208MFG
+ PACKAGES:=-firewall -dropbear -dnsmasq -mtd -ppp -wpad-mini block-mount kmod-usb-storage kmod-usb2 kmod-usb-ohci -iptables -kmod-switch kmod-fs-ext4 block-extroot
+endef
+
+define Profile/Ps1208mfg/Description
+ Package set optimize for edimax PS-1208MFG printserver
+endef
+
+$(eval $(call Profile,Ps1208mfg))
+
diff --git a/target/linux/brcm47xx/profiles/WGT634U.mk b/target/linux/brcm47xx/profiles/WGT634U.mk
new file mode 100644
index 000000000..81f59a729
--- /dev/null
+++ b/target/linux/brcm47xx/profiles/WGT634U.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WGT634U
+ NAME:=Netgear WGT634U
+ PACKAGES:=kmod-ath5k kmod-usb-core kmod-usb2 kmod-ocf kmod-crypto-ocf-ubsec-ssb
+endef
+
+define Profile/WGT634U/Description
+ Package set compatible with the Netgear WGT634U. Contains USB support
+endef
+$(eval $(call Profile,WGT634U))
+
diff --git a/target/linux/brcm47xx/profiles/WL500GPv1-ATH.mk b/target/linux/brcm47xx/profiles/WL500GPv1-ATH.mk
new file mode 100644
index 000000000..4d50db347
--- /dev/null
+++ b/target/linux/brcm47xx/profiles/WL500GPv1-ATH.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WL500GPv1
+ NAME:=ASUS WL-500g Premium v1 (Atheros WiFi using ath5k)
+ PACKAGES:=kmod-ath5k kmod-usb-core kmod-usb-uhci kmod-usb2
+endef
+
+define Profile/WL500GPv1/Description
+ Package set optimized for the WL-500g Premium v1 with USB and Atheros WiFi card support
+endef
+$(eval $(call Profile,WL500GPv1))
diff --git a/target/linux/brcm47xx/profiles/WRT350Nv1.mk b/target/linux/brcm47xx/profiles/WRT350Nv1.mk
new file mode 100644
index 000000000..82be93aa8
--- /dev/null
+++ b/target/linux/brcm47xx/profiles/WRT350Nv1.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WRT350Nv1
+ NAME:=Linksys WRT350Nv1
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ssb-gige kmod-ocf-ubsec-ssb
+endef
+
+define Profile/WRT350Nv1/Description
+ Package set compatible with the Linksys WRT350Nv1. Contains USB support
+endef
+$(eval $(call Profile,WRT350Nv1))
diff --git a/target/linux/brcm47xx/profiles/WRTSL54GS.mk b/target/linux/brcm47xx/profiles/WRTSL54GS.mk
new file mode 100644
index 000000000..0e53c7d13
--- /dev/null
+++ b/target/linux/brcm47xx/profiles/WRTSL54GS.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WRTSL54GS
+ NAME:=Linksys WRTSL54GS
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage kmod-scsi-core kmod-fs-ext3 e2fsprogs kmod-b43
+endef
+
+define Profile/WRTSL54GS/Description
+ Package set compatible with the Linksys WRTSL54GS. Contains USB support
+endef
+$(eval $(call Profile,WRTSL54GS))
+