aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-14 16:36:31 +0000
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-14 16:36:31 +0000
commit89594109e7bcbc129324b0c17bcb83158fb0e26a (patch)
treed50c906868f84fc37df6d759c06b1d74b2290b54 /target/linux/ar71xx
parent7fc94810d3cbe8770b2edbcb8a3c59a9dcf9ad83 (diff)
downloadopenwrt-89594109e7bcbc129324b0c17bcb83158fb0e26a.tar.gz
openwrt-89594109e7bcbc129324b0c17bcb83158fb0e26a.zip
AA: ar71xx: unbreak building images for OpenMesh OM2P/OM2P-LC
Backport of r33767. Commit r33248 introduced a regression by passing the board name plus 'board=' in the third argument. The board name string has to be put into the image as identifier of the image type. [juhosg: fix OpenMesh template instead of use of string substitution] Signed-off-by: Marek Lindner <lindner_marek@yahoo.de> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33770 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 569bdc9ef..2e3c18413 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -641,7 +641,7 @@ define Image/Build/OpenMesh
"$(KDIR_TMP)/vmlinux-$(2).uImage" \
"$(KDIR)/root.$(1)"
-sh $(TOPDIR)/scripts/combined-ext-image.sh \
- "$(3)" "$(call factoryname,$(1),$(2))" \
+ "$(4)" "$(call factoryname,$(1),$(2))" \
"$(BUILD_DIR)/om2p-fwupgrade.cfg" "fwupgrade.cfg" \
"$(KDIR_TMP)/vmlinux-$(2).uImage" "kernel" \
"$(KDIR)/root.$(1)" "rootfs"
@@ -781,7 +781,7 @@ $(eval $(call SingleProfile,Netgear,$(fs_64k),WNDR3800,wndr3800,WNDR3700,ttyS0,1
$(eval $(call SingleProfile,Netgear,$(fs_64k),WNDRMAC,wndrmac,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),3701,WNDRMAC,"",-H 29763654+16+64))
$(eval $(call SingleProfile,Netgear,$(fs_64k),WNDRMACV2,wndrmacv2,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),3701,WNDRMACv2,"",-H 29763654+16+128))
-$(eval $(call SingleProfile,OpenMesh,$(fs_squash),OM2P,om2p,OM2P))
+$(eval $(call SingleProfile,OpenMesh,$(fs_squash),OM2P,om2p,,,,OM2P))
$(eval $(call SingleProfile,PB4X,$(fs_128k),ALL0305,all0305,ALL0305,ttyS0,115200))
$(eval $(call SingleProfile,PB4X,$(fs_128k),EAP7660D,eap7660d,EAP7660D,ttyS0,115200))