aboutsummaryrefslogtreecommitdiffstats
path: root/package/ocf-crypto-headers/Makefile
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
commit5c105d9f3fd086aff195d3849dcf847d6b0bd927 (patch)
tree1229a11f725bfa58aa7c57a76898553bb5f6654a /package/ocf-crypto-headers/Makefile
downloadopenwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.tar.gz
openwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.zip
branch Attitude Adjustment
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ocf-crypto-headers/Makefile')
-rw-r--r--package/ocf-crypto-headers/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/package/ocf-crypto-headers/Makefile b/package/ocf-crypto-headers/Makefile
new file mode 100644
index 000000000..fee2a3734
--- /dev/null
+++ b/package/ocf-crypto-headers/Makefile
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2008-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ocf-crypto-headers
+PKG_VERSION:=20110720
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ocf-crypto-headers
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=OCF-Linux cryptodev header
+ PKGARCH:=all
+ URL:=http://ocf-linux.sourceforge.net/
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Build/InstallDev
+ mkdir -p $(1)/usr/include/crypto
+ $(CP) ./src/cryptodev.h $(1)/usr/include/crypto
+endef
+
+$(eval $(call BuildPackage,ocf-crypto-headers))