aboutsummaryrefslogtreecommitdiffstats
path: root/package/ltq-tapidemo/patches
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
commit5c105d9f3fd086aff195d3849dcf847d6b0bd927 (patch)
tree1229a11f725bfa58aa7c57a76898553bb5f6654a /package/ltq-tapidemo/patches
downloadopenwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.tar.gz
openwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.zip
branch Attitude Adjustment
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ltq-tapidemo/patches')
-rw-r--r--package/ltq-tapidemo/patches/100-ifxmips.patch61
-rw-r--r--package/ltq-tapidemo/patches/110-filename.patch141
2 files changed, 202 insertions, 0 deletions
diff --git a/package/ltq-tapidemo/patches/100-ifxmips.patch b/package/ltq-tapidemo/patches/100-ifxmips.patch
new file mode 100644
index 000000000..3dde8304f
--- /dev/null
+++ b/package/ltq-tapidemo/patches/100-ifxmips.patch
@@ -0,0 +1,61 @@
+--- a/src/board_easy50712.c
++++ b/src/board_easy50712.c
+@@ -32,7 +32,9 @@
+ #ifdef OLD_BSP
+ #include "asm/danube/port.h"
+ #else
+- #include "asm/ifx/ifx_gpio.h"
++#ifdef FXO
++# include "asm/ifx/ifx_gpio.h"
++#endif
+ #endif
+
+ /* ============================= */
+--- a/src/board_easy508xx.c
++++ b/src/board_easy508xx.c
+@@ -32,8 +32,6 @@
+ #endif /* FXO */
+ #include "pcm.h"
+
+-#include "asm/ifx/ifx_gpio.h"
+-
+ #ifdef TD_DECT
+ #include "td_dect.h"
+ #endif /* TD_DECT */
+--- a/src/common.c
++++ b/src/common.c
+@@ -7117,7 +7117,7 @@ IFX_return_t Common_GPIO_ClosePort(IFX_c
+ IFX_return_t Common_GPIO_ReservePin(IFX_int32_t nFd, IFX_int32_t nPort,
+ IFX_int32_t nPin, IFX_int32_t nModule)
+ {
+-#ifndef OLD_BSP
++#if !defined(OLD_BSP) && defined(IFX_GPIO_IOC_PIN_RESERVE)
+ TD_PARAMETER_CHECK((NO_GPIO_FD >= nFd), nFd, IFX_ERROR);
+
+ IFX_return_t nRet;
+@@ -7155,7 +7155,7 @@ IFX_return_t Common_GPIO_ReservePin(IFX_
+ IFX_return_t Common_GPIO_FreePin(IFX_int32_t nFd, IFX_int32_t nPort,
+ IFX_int32_t nPin, IFX_int32_t nModule)
+ {
+-#ifndef OLD_BSP
++#if !defined(OLD_BSP) && defined(IFX_GPIO_IOC_PIN_RESERVE)
+ TD_PARAMETER_CHECK((NO_GPIO_FD >= nFd), nFd, IFX_ERROR);
+
+ IFX_return_t nRet;
+--- a/src/common.h
++++ b/src/common.h
+@@ -79,12 +79,12 @@
+ #ifdef OLD_BSP
+ #include "asm/danube/port.h"
+ #else
+- #include "asm/ifx/ifx_gpio.h"
++ /*#include "asm/ifx/ifx_gpio.h"*/
+ #endif
+ #endif
+
+ #if (defined(AR9) || defined(VR9))
+- #include "asm/ifx/ifx_gpio.h"
++ /*#include "asm/ifx/ifx_gpio.h"*/
+ #endif
+
+ #ifdef TD_DECT
diff --git a/package/ltq-tapidemo/patches/110-filename.patch b/package/ltq-tapidemo/patches/110-filename.patch
new file mode 100644
index 000000000..73c2e977b
--- /dev/null
+++ b/package/ltq-tapidemo/patches/110-filename.patch
@@ -0,0 +1,141 @@
+--- a/configure.in
++++ b/configure.in
+@@ -1665,6 +1665,30 @@ AC_ARG_WITH(cflags,
+ ]
+ )
+
++dnl overwrite default FW file name
++AC_ARG_WITH(fw-file,
++ AS_HELP_STRING(
++ [--with-fw-file=val],
++ [overwrite default FW file name]
++ ),
++ [
++ AC_MSG_RESULT([using firmware file $withval])
++ AC_DEFINE_UNQUOTED([TD_FW_FILE], ["$withval"], [using firmware file])
++ ]
++)
++
++dnl overwrite default BBD file name
++AC_ARG_WITH(bbd-file,
++ AS_HELP_STRING(
++ [--with-bbd-file=val],
++ [overwrite default BBD file name]
++ ),
++ [
++ AC_MSG_RESULT([using BBD file $withval])
++ AC_DEFINE_UNQUOTED([TD_BBD_FILE], ["$withval"], [using BBD file])
++ ]
++)
++
+ AC_CONFIG_FILES([Makefile])
+ AC_CONFIG_FILES([src/Makefile])
+
+--- a/src/device_vmmc.c
++++ b/src/device_vmmc.c
+@@ -49,40 +49,55 @@
+
+
+ #ifdef USE_FILESYSTEM
++#ifdef TD_BBD_FILE
++ IFX_char_t* sBBD_CRAM_File_VMMC = TD_BBD_FILE;
++ IFX_char_t* sBBD_CRAM_File_VMMC_Old = TD_BBD_FILE;
++#else
++ /** File holding coefficients. */
++#ifdef DANUBE
++ /** Prepare file names for DANUBE */
++ IFX_char_t* sBBD_CRAM_File_VMMC = "danube_bbd.bin";
++ IFX_char_t* sBBD_CRAM_File_VMMC_Old = "danube_bbd_fxs.bin";
++#elif AR9
++ IFX_char_t* sBBD_CRAM_File_VMMC = "ar9_bbd.bin";
++ IFX_char_t* sBBD_CRAM_File_VMMC_Old = "ar9_bbd_fxs.bin";
++#elif VINAX
++ IFX_char_t* sBBD_CRAM_File_VMMC = "bbd.bin";
++ IFX_char_t* sBBD_CRAM_File_VMMC_Old = "";
++#elif VR9
++ IFX_char_t* sBBD_CRAM_File_VMMC = "vr9_bbd.bin";
++ IFX_char_t* sBBD_CRAM_File_VMMC_Old = "vr9_bbd_fxs.bin";
++#else
++#endif
++#endif /* TD_BBD_FILE */
++#ifdef TD_FW_FILE
++ IFX_char_t* sPRAMFile_VMMC = TD_FW_FILE;
++ IFX_char_t* sPRAMFile_VMMC_Old = TD_FW_FILE;
++ IFX_char_t* sDRAMFile_VMMC = "";
++#else
+ #ifdef DANUBE
+ /** Prepare file names for DANUBE */
+ IFX_char_t* sPRAMFile_VMMC = "voice_danube_firmware.bin";
+ IFX_char_t* sPRAMFile_VMMC_Old = "danube_firmware.bin";
+ IFX_char_t* sDRAMFile_VMMC = "";
+- /** File holding coefficients. */
+- IFX_char_t* sBBD_CRAM_File_VMMC = "danube_bbd.bin";
+- IFX_char_t* sBBD_CRAM_File_VMMC_Old = "danube_bbd_fxs.bin";
+ #elif AR9
+ /** Prepare file names for AR9 */
+ IFX_char_t* sPRAMFile_VMMC = "voice_ar9_firmware.bin";
+ IFX_char_t* sPRAMFile_VMMC_Old = "ar9_firmware.bin";
+ IFX_char_t* sDRAMFile_VMMC = "";
+- /** File holding coefficients. */
+- IFX_char_t* sBBD_CRAM_File_VMMC = "ar9_bbd.bin";
+- IFX_char_t* sBBD_CRAM_File_VMMC_Old = "ar9_bbd_fxs.bin";
+ #elif VINAX
+ /** Prepare file names for VINAX */
+ IFX_char_t* sPRAMFile_VMMC = "voice_vinax_firmware.bin";
+ IFX_char_t* sPRAMFile_VMMC_Old = "firmware.bin";
+ IFX_char_t* sDRAMFile_VMMC = "";
+- /** File holding coefficients. */
+- IFX_char_t* sBBD_CRAM_File_VMMC = "bbd.bin";
+- IFX_char_t* sBBD_CRAM_File_VMMC_Old = "";
+ #elif VR9
+ /** Prepare file names for VR9 */
+ IFX_char_t* sPRAMFile_VMMC = "voice_vr9_firmware.bin";
+ IFX_char_t* sPRAMFile_VMMC_Old = "vr9_firmware.bin";
+ IFX_char_t* sDRAMFile_VMMC = "";
+- /** File holding coefficients. */
+- IFX_char_t* sBBD_CRAM_File_VMMC = "vr9_bbd.bin";
+- IFX_char_t* sBBD_CRAM_File_VMMC_Old = "vr9_bbd_fxs.bin";
+ #else
+ #endif
++#endif /* TD_FW_FILE */
+ #endif /* USE_FILESYSTEM */
+
+ /** Device names */
+--- a/src/common.c
++++ b/src/common.c
+@@ -509,6 +509,10 @@ IFX_return_t Common_CheckDownloadPath(IF
+ if (IFX_TRUE != Common_FindBBD_CRAM(pCpuDevice, psPath, psFile))
+ {
+ ret = IFX_ERROR;
++ if(bPrintTrace)
++ TRACE(TAPIDEMO, DBG_LEVEL_LOW,
++ ("Download path %s does not contain the required file %s.\n",
++ psPath, psFile));
+ }
+
+ if ((IFX_SUCCESS == ret) &&
+@@ -521,6 +525,10 @@ IFX_return_t Common_CheckDownloadPath(IF
+ {
+ ret = Common_CheckFileExists(psFile);
+ }
++ if(bPrintTrace && ret != IFX_SUCCESS)
++ TRACE(TAPIDEMO, DBG_LEVEL_LOW,
++ ("Download path %s does not contain the required file %s.\n",
++ psPath, psFile));
+ }
+ #ifndef TAPI_VERSION4
+ if (IFX_SUCCESS == ret)
+@@ -532,13 +540,6 @@ IFX_return_t Common_CheckDownloadPath(IF
+ }
+ #endif
+
+- if (IFX_ERROR == ret)
+- {
+- if(bPrintTrace)
+- TRACE(TAPIDEMO, DBG_LEVEL_LOW,
+- ("Download path %s does not contain the required files.\n",
+- psPath));
+- }
+
+ return ret;
+ } /* Common_CheckDownloadPath */