aboutsummaryrefslogtreecommitdiffstats
path: root/package/hotplug2/patches/110-static_worker.patch
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
commit5c105d9f3fd086aff195d3849dcf847d6b0bd927 (patch)
tree1229a11f725bfa58aa7c57a76898553bb5f6654a /package/hotplug2/patches/110-static_worker.patch
downloadopenwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.tar.gz
openwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.zip
branch Attitude Adjustment
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/hotplug2/patches/110-static_worker.patch')
-rw-r--r--package/hotplug2/patches/110-static_worker.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/hotplug2/patches/110-static_worker.patch b/package/hotplug2/patches/110-static_worker.patch
new file mode 100644
index 000000000..3a5181f74
--- /dev/null
+++ b/package/hotplug2/patches/110-static_worker.patch
@@ -0,0 +1,20 @@
+--- a/common.mak
++++ b/common.mak
+@@ -1,7 +1,7 @@
+ # vim:set sw=8 nosta:
+
+ COPTS=-Os -Wall -g
+-LDFLAGS=-g -ldl
++LDFLAGS=-g
+
+ CFLAGS=$(COPTS)
+ FPIC=-fPIC
+--- a/Makefile
++++ b/Makefile
+@@ -40,5 +40,6 @@ ifdef STATIC_WORKER
+ CFLAGS += -DSTATIC_WORKER=1
+ else
+ CFLAGS += $(FPIC)
++ LDFLAGS += -ldl
+ endif
+