aboutsummaryrefslogtreecommitdiffstats
path: root/include/toolchain-build.mk
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
commit5c105d9f3fd086aff195d3849dcf847d6b0bd927 (patch)
tree1229a11f725bfa58aa7c57a76898553bb5f6654a /include/toolchain-build.mk
downloadopenwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.tar.gz
openwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.zip
branch Attitude Adjustment
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/toolchain-build.mk')
-rw-r--r--include/toolchain-build.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/include/toolchain-build.mk b/include/toolchain-build.mk
new file mode 100644
index 000000000..d2fdb0281
--- /dev/null
+++ b/include/toolchain-build.mk
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+override CONFIG_AUTOREBUILD=
+
+REAL_STAGING_DIR_HOST:=$(STAGING_DIR_HOST)
+STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
+BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
+
+TOOLCHAIN_JOBS?=$(if $(CONFIG_TOOLCHAIN_PARALLEL),-j$(CONFIG_PKG_BUILD_JOBS))
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared
+
+define FixupLibdir
+ if [ -d $(1)/lib64 -a \! -L $(1)/lib64 ]; then \
+ mkdir -p $(1)/lib; \
+ mv $(1)/lib64/* $(1)/lib/; \
+ rm -rf $(1)/lib64; \
+ fi
+ ln -sf lib $(1)/lib64
+endef