aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-10 11:43:50 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-10 11:43:50 +0000
commit3caf621121b5bafc61251cf659e15492e61897a7 (patch)
tree09074af10610aba10498049aea0e75ae629fc045
parent041cd34c5ad8a78ac3275539dcdcf673c814dfe3 (diff)
downloadopenwrt-3caf621121b5bafc61251cf659e15492e61897a7.tar.gz
openwrt-3caf621121b5bafc61251cf659e15492e61897a7.zip
ixp4xx, cns3xx: backport the latest round of fixes (as of r33684)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33685 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/ixp4xx-microcode/Makefile1
-rw-r--r--package/ixp4xx-microcode/src/IxNpeMicrocode.h8
-rw-r--r--package/kernel/modules/sound.mk19
-rw-r--r--target/linux/cns3xxx/patches-3.3/300-laguna_support.patch25
-rw-r--r--target/linux/generic/patches-3.3/478-mtd-partial_eraseblock_unlock.patch18
-rw-r--r--target/linux/ixp4xx/config-3.31
6 files changed, 69 insertions, 3 deletions
diff --git a/package/ixp4xx-microcode/Makefile b/package/ixp4xx-microcode/Makefile
index 9ed912758..52b44f35f 100644
--- a/package/ixp4xx-microcode/Makefile
+++ b/package/ixp4xx-microcode/Makefile
@@ -48,6 +48,7 @@ define Package/ixp4xx-microcode/install
$(INSTALL_DIR) $(1)/lib/firmware
$(INSTALL_DIR) $(1)/usr/share/doc
$(INSTALL_BIN) $(PKG_BUILD_DIR)/NPE-A $(1)/lib/firmware/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/NPE-A-HSS $(1)/lib/firmware/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/NPE-B $(1)/lib/firmware/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/NPE-C $(1)/lib/firmware/
$(INSTALL_DATA) $(PKG_BUILD_DIR)/LICENSE.IPL $(1)/usr/share/doc/
diff --git a/package/ixp4xx-microcode/src/IxNpeMicrocode.h b/package/ixp4xx-microcode/src/IxNpeMicrocode.h
index ffb22b200..4a843db10 100644
--- a/package/ixp4xx-microcode/src/IxNpeMicrocode.h
+++ b/package/ixp4xx-microcode/src/IxNpeMicrocode.h
@@ -27,7 +27,7 @@
#define IX_NPEDL_NPEIMAGE_NPEA_ETH_SPAN_FIREWALL_VLAN_QOS_HDR_CONV
// #define IX_NPEDL_NPEIMAGE_NPEA_ETH_LEARN_FILTER_SPAN_FIREWALL_VLAN_QOS
// #define IX_NPEDL_NPEIMAGE_NPEA_ETH_LEARN_FILTER_SPAN_FIREWALL
-// #define IX_NPEDL_NPEIMAGE_NPEA_HSS_2_PORT
+#define IX_NPEDL_NPEIMAGE_NPEA_HSS_2_PORT
// #define IX_NPEDL_NPEIMAGE_NPEA_DMA
// #define IX_NPEDL_NPEIMAGE_NPEA_ATM_MPHY_12_PORT
// #define IX_NPEDL_NPEIMAGE_NPEA_HSS0_ATM_MPHY_1_PORT
@@ -118,7 +118,11 @@ int main(int argc, char *argv[])
sprintf(filename, "NPE-%c.%08x", (field[0] & 0xf) + 'A',
image->id);
- sprintf(slnk, "NPE-%c", (field[0] & 0xf) + 'A');
+ if (image->id == 0x00090000)
+ sprintf(slnk, "NPE-%c-HSS", (field[0] & 0xf) + 'A');
+ else
+ sprintf(slnk, "NPE-%c", (field[0] & 0xf) + 'A');
+
printf("Writing image: %s.NPE_%c Func: %2x Rev: %02x.%02x "
"Size: %5d to: '%s'\n",
names[field[0] >> 4], (field[0] & 0xf) + 'A',
diff --git a/package/kernel/modules/sound.mk b/package/kernel/modules/sound.mk
index f054d870c..4ccdc8b80 100644
--- a/package/kernel/modules/sound.mk
+++ b/package/kernel/modules/sound.mk
@@ -182,3 +182,22 @@ define KernelPackage/sound-soc-ac97
endef
$(eval $(call KernelPackage,sound-soc-ac97))
+
+
+define KernelPackage/sound-soc-gw_avila
+ TITLE:=Gateworks Avila SoC sound support
+ KCONFIG:= \
+ CONFIG_SND_GW_AVILA_SOC \
+ CONFIG_SND_GW_AVILA_SOC_PCM \
+ CONFIG_SND_GW_AVILA_SOC_HSS
+ FILES:= \
+ $(LINUX_DIR)/sound/soc/codecs/snd-soc-tlv320aic3x.ko \
+ $(LINUX_DIR)/sound/soc/gw-avila/snd-soc-gw-avila.ko \
+ $(LINUX_DIR)/sound/soc/gw-avila/snd-soc-gw-avila-pcm.ko \
+ $(LINUX_DIR)/sound/soc/gw-avila/snd-soc-gw-avila-hss.ko
+ AUTOLOAD:=$(call AutoLoad,65,snd-soc-tlv320aic3x snd-soc-gw-avila snd-soc-gw-avila-pcm snd-soc-gw-avila-hss)
+ DEPENDS:=@TARGET_ixp4xx +kmod-sound-soc-core
+ $(call AddDepends/sound)
+endef
+
+$(eval $(call KernelPackage,sound-soc-gw_avila))
diff --git a/target/linux/cns3xxx/patches-3.3/300-laguna_support.patch b/target/linux/cns3xxx/patches-3.3/300-laguna_support.patch
index 7fe970a4d..b42606b50 100644
--- a/target/linux/cns3xxx/patches-3.3/300-laguna_support.patch
+++ b/target/linux/cns3xxx/patches-3.3/300-laguna_support.patch
@@ -563,7 +563,7 @@
+
+static struct resource laguna_watchdog_resources[] = {
+ [0] = {
-+ .start = CNS3XXX_TC11MP_TWD_BASE,
++ .start = CNS3XXX_TC11MP_TWD_BASE + 0x100, // CPU0 watchdog
+ .end = CNS3XXX_TC11MP_TWD_BASE + SZ_4K - 1,
+ .flags = IORESOURCE_MEM,
+ },
@@ -963,3 +963,26 @@
obj-$(CONFIG_SMP) += platsmp.o headsmp.o
obj-$(CONFIG_HOTPLUG_CPU) += hotplug.o
obj-$(CONFIG_LOCAL_TIMERS) += localtimer.o
+--- a/arch/arm/mach-cns3xxx/devices.c
++++ b/arch/arm/mach-cns3xxx/devices.c
+@@ -19,6 +19,7 @@
+ #include <mach/cns3xxx.h>
+ #include <mach/irqs.h>
+ #include <mach/pm.h>
++#include <asm/mach-types.h>
+ #include "core.h"
+ #include "devices.h"
+
+@@ -102,7 +103,11 @@ void __init cns3xxx_sdhci_init(void)
+ u32 gpioa_pins = __raw_readl(gpioa);
+
+ /* MMC/SD pins share with GPIOA */
+- gpioa_pins |= 0x1fff0004;
++ if (machine_is_gw2388()) {
++ gpioa_pins |= 0x1fff0000;
++ } else {
++ gpioa_pins |= 0x1fff0004;
++ }
+ __raw_writel(gpioa_pins, gpioa);
+
+ cns3xxx_pwr_clk_en(CNS3XXX_PWR_CLK_EN(SDIO));
diff --git a/target/linux/generic/patches-3.3/478-mtd-partial_eraseblock_unlock.patch b/target/linux/generic/patches-3.3/478-mtd-partial_eraseblock_unlock.patch
new file mode 100644
index 000000000..de4481a93
--- /dev/null
+++ b/target/linux/generic/patches-3.3/478-mtd-partial_eraseblock_unlock.patch
@@ -0,0 +1,18 @@
+--- a/drivers/mtd/mtdpart.c
++++ b/drivers/mtd/mtdpart.c
+@@ -356,7 +356,14 @@ static int part_unlock(struct mtd_info *
+ struct mtd_part *part = PART(mtd);
+ if ((len + ofs) > mtd->size)
+ return -EINVAL;
+- return mtd_unlock(part->master, ofs + part->offset, len);
++
++ ofs += part->offset;
++ if (mtd->flags & MTD_ERASE_PARTIAL) {
++ /* round up len to next erasesize and round down offset to prev block */
++ len = (mtd_div_by_eb(len, part->master) + 1) * part->master->erasesize;
++ ofs &= ~(part->master->erasesize - 1);
++ }
++ return mtd_unlock(part->master, ofs, len);
+ }
+
+ static int part_is_locked(struct mtd_info *mtd, loff_t ofs, uint64_t len)
diff --git a/target/linux/ixp4xx/config-3.3 b/target/linux/ixp4xx/config-3.3
index 3d90775c5..54a0ebbb4 100644
--- a/target/linux/ixp4xx/config-3.3
+++ b/target/linux/ixp4xx/config-3.3
@@ -24,6 +24,7 @@ CONFIG_ARM_PATCH_PHYS_VIRT=y
CONFIG_BCMA_POSSIBLE=y
CONFIG_BOUNCE=y
# CONFIG_CACHE_L2X0 is not set
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_CLKSRC_MMIO=y
CONFIG_CMDLINE="root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200"
CONFIG_CMDLINE_FROM_BOOTLOADER=y