aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-11-09 11:16:53 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-11-09 11:16:53 +0000
commitb93c52acfff7fec2ee3bd02207d460ee71d36080 (patch)
tree131a607e6bd0687dc8f9c063124c0b2ffe7e6bf8
parentedfd27d24b69f83fe37434f77b131c4c8070f5e2 (diff)
downloadopenwrt-b93c52acfff7fec2ee3bd02207d460ee71d36080.tar.gz
openwrt-b93c52acfff7fec2ee3bd02207d460ee71d36080.zip
x86: backport grub2 at_keyboard handling from r34126 and r34127
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@34128 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/x86/image/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 547f0839f..13da511ed 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
export PATH=$(TARGET_PATH):/sbin
-GRUB2_MODULES = at_keyboard biosdisk boot chain configfile ext2 linux ls part_msdos reboot serial vga
+GRUB2_MODULES = biosdisk boot chain configfile ext2 linux ls part_msdos reboot serial vga
GRUB_TERMINALS =
GRUB_SERIAL_CONFIG =
GRUB_TERMINAL_CONFIG =
@@ -20,6 +20,12 @@ ifneq ($(CONFIG_X86_GRUB_CONSOLE),)
GRUB_TERMINALS += console
endif
+USE_ATKBD = generic kvm_guest
+
+ifneq ($(strip $(foreach subtarget,$(USE_ATKBD),$(CONFIG_TARGET_x86_$(subtarget)))),)
+ GRUB2_MODULES += at_keyboard
+endif
+
ifneq ($(CONFIG_X86_GRUB_SERIAL),)
GRUB_CONSOLE_CMDLINE += console=$(call qstrip,$(CONFIG_X86_GRUB_SERIAL)),$(CONFIG_X86_GRUB_BAUDRATE)n8
GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_X86_GRUB_BAUDRATE) --word=8 --parity=no --stop=1