summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@archive.org>2021-10-27 15:19:23 -0700
committerBryan Newbold <bnewbold@archive.org>2021-10-27 15:19:25 -0700
commit6a34c0b8d5976bb35aecf3c794166e711b338f18 (patch)
tree5a6bd64ca4eb70b855d15a09d67fe174262443df /setup.py
parent6812d37a27dae1e22ea45124576d7ed2d63695c6 (diff)
downloadgrobid_tei_xml-6a34c0b8d5976bb35aecf3c794166e711b338f18.tar.gz
grobid_tei_xml-6a34c0b8d5976bb35aecf3c794166e711b338f18.zip
update lint/fmt/test tools and configuration
yapf => black isort config mypy configuration flake8 configuration
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 7b724f4..d9f1176 100644
--- a/setup.py
+++ b/setup.py
@@ -62,12 +62,13 @@ with open("README.md", "r") as fh:
python_requires=">=3.7",
install_requires=[],
extras_require={"dev": [
- #"isort",
+ # black
+ "isort",
"mypy",
- "pylint",
"pytest",
+ "pytest",
+ "pytest-codeblocks",
"pytest-cov",
- "yapf",
],},
cmdclass={
'upload': UploadCommand,