aboutsummaryrefslogtreecommitdiffstats
path: root/rust/fatcat-api-spec/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@robocracy.org>2018-09-11 13:59:32 -0700
committerBryan Newbold <bnewbold@robocracy.org>2018-09-11 13:59:32 -0700
commitcd8e09fcb6ee0a1b23c0bd57d0f097f99fd6d828 (patch)
treefbd5c91c576a2fce2c44cfe36e5754b69aedc046 /rust/fatcat-api-spec/Cargo.toml
parent0dc872921023030f6ffd320eb038e5379b47fa53 (diff)
downloadfatcat-cd8e09fcb6ee0a1b23c0bd57d0f097f99fd6d828.tar.gz
fatcat-cd8e09fcb6ee0a1b23c0bd57d0f097f99fd6d828.zip
refactor fatcat-api => fatcat-api-spec
Diffstat (limited to 'rust/fatcat-api-spec/Cargo.toml')
-rw-r--r--rust/fatcat-api-spec/Cargo.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/rust/fatcat-api-spec/Cargo.toml b/rust/fatcat-api-spec/Cargo.toml
new file mode 100644
index 00000000..72758cb4
--- /dev/null
+++ b/rust/fatcat-api-spec/Cargo.toml
@@ -0,0 +1,43 @@
+[package]
+name = "fatcat-api-spec"
+version = "0.1.0"
+authors = ["Bryan Newbold <bnewbold@archive.org>"]
+description = "HTTP API models, endpoints, and other auto-generated types"
+license = "CC-0"
+
+[features]
+default = ["client", "server"]
+client = ["serde_json", "serde_ignored", "hyper", "hyper-openssl", "uuid"]
+server = ["serde_json", "serde_ignored", "hyper", "iron", "router", "bodyparser", "urlencoded", "uuid"]
+
+[dependencies]
+# Required by example server.
+#
+chrono = { version = "0.4", features = ["serde"] }
+futures = "0.1"
+hyper = {version = "0.10", optional = true}
+hyper-openssl = {version = "0.2", optional = true }
+iron = {version = "0.5", optional = true}
+swagger = "0.7"
+
+# Not required by example server.
+#
+bodyparser = {version = "0.7", optional = true}
+url = "1.5"
+lazy_static = "0.2"
+log = "0.3.0"
+multipart = {version = "0.13", optional = true}
+router = {version = "0.5", optional = true}
+serde = "1.0"
+serde_derive = "1.0"
+serde_ignored = {version = "0.0.4", optional = true}
+serde_json = {version = "1.0", optional = true}
+urlencoded = {version = "0.5", optional = true}
+uuid = {version = "0.5", optional = true, features = ["serde", "v4"]}
+# ToDo: this should be updated to point at the official crate once
+# https://github.com/RReverser/serde-xml-rs/pull/45 is accepted upstream
+
+
+[dev-dependencies]
+clap = "2.25"
+error-chain = "0.11"