aboutsummaryrefslogtreecommitdiffstats
path: root/rust/fatcat-api-spec/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@robocracy.org>2018-09-11 14:49:06 -0700
committerBryan Newbold <bnewbold@robocracy.org>2018-09-11 14:49:06 -0700
commit2aef3c1dbf75ae374862a12e6d6a680d9ce78720 (patch)
treed595f90f4843e1084373e0d06db91fe3bc970157 /rust/fatcat-api-spec/Cargo.toml
parent1603ce316f1e611bf82b959b6d9b2ada1e769c32 (diff)
downloadfatcat-2aef3c1dbf75ae374862a12e6d6a680d9ce78720.tar.gz
fatcat-2aef3c1dbf75ae374862a12e6d6a680d9ce78720.zip
fix fatcat-api-spec deps
Diffstat (limited to 'rust/fatcat-api-spec/Cargo.toml')
-rw-r--r--rust/fatcat-api-spec/Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/rust/fatcat-api-spec/Cargo.toml b/rust/fatcat-api-spec/Cargo.toml
index 72758cb4..4e70af06 100644
--- a/rust/fatcat-api-spec/Cargo.toml
+++ b/rust/fatcat-api-spec/Cargo.toml
@@ -17,22 +17,22 @@ chrono = { version = "0.4", features = ["serde"] }
futures = "0.1"
hyper = {version = "0.10", optional = true}
hyper-openssl = {version = "0.2", optional = true }
-iron = {version = "0.5", optional = true}
+iron = {version = "0.6", optional = true}
swagger = "0.7"
# Not required by example server.
#
-bodyparser = {version = "0.7", optional = true}
+bodyparser = {version = "0.8", optional = true}
url = "1.5"
lazy_static = "0.2"
log = "0.3.0"
multipart = {version = "0.13", optional = true}
-router = {version = "0.5", optional = true}
+router = {version = "0.6", optional = true}
serde = "1.0"
serde_derive = "1.0"
serde_ignored = {version = "0.0.4", optional = true}
serde_json = {version = "1.0", optional = true}
-urlencoded = {version = "0.5", optional = true}
+urlencoded = {version = "0.6", optional = true}
uuid = {version = "0.5", optional = true, features = ["serde", "v4"]}
# ToDo: this should be updated to point at the official crate once
# https://github.com/RReverser/serde-xml-rs/pull/45 is accepted upstream