aboutsummaryrefslogtreecommitdiffstats
path: root/rust/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@robocracy.org>2018-09-11 13:59:32 -0700
committerBryan Newbold <bnewbold@robocracy.org>2018-09-11 13:59:32 -0700
commitcd8e09fcb6ee0a1b23c0bd57d0f097f99fd6d828 (patch)
treefbd5c91c576a2fce2c44cfe36e5754b69aedc046 /rust/Cargo.toml
parent0dc872921023030f6ffd320eb038e5379b47fa53 (diff)
downloadfatcat-cd8e09fcb6ee0a1b23c0bd57d0f097f99fd6d828.tar.gz
fatcat-cd8e09fcb6ee0a1b23c0bd57d0f097f99fd6d828.zip
refactor fatcat-api => fatcat-api-spec
Diffstat (limited to 'rust/Cargo.toml')
-rw-r--r--rust/Cargo.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/rust/Cargo.toml b/rust/Cargo.toml
index 67318f26..6b2e1ffe 100644
--- a/rust/Cargo.toml
+++ b/rust/Cargo.toml
@@ -2,12 +2,14 @@
name = "fatcat"
version = "0.1.0"
authors = ["Bryan Newbold <bnewbold@archive.org>"]
+description = "A scalable, versioned, API-oriented catalog of bibliographic entities and file metadata"
+license = "AGPL 3.0"
[workspace]
-members = ["fatcat-api"]
+members = ["fatcat-api-spec"]
[dependencies]
-fatcat-api = {version = "*", path = "fatcat-api"}
+fatcat-api-spec = {version = "*", path = "fatcat-api-spec"}
diesel = { version = "1.3", features = ["postgres", "uuid", "serde_json", "chrono", "r2d2"] }
diesel_migrations = "1.3"
dotenv = "0.9.0"