summaryrefslogtreecommitdiffstats
path: root/rust/fatcat-openapi/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/fatcat-openapi/Cargo.toml')
-rw-r--r--rust/fatcat-openapi/Cargo.toml32
1 files changed, 17 insertions, 15 deletions
diff --git a/rust/fatcat-openapi/Cargo.toml b/rust/fatcat-openapi/Cargo.toml
index 7e5a5c6..b35a016 100644
--- a/rust/fatcat-openapi/Cargo.toml
+++ b/rust/fatcat-openapi/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "fatcat-openapi"
-version = "0.3.1"
+version = "0.3.3"
edition = "2018"
authors = ["Bryan Newbold <bnewbold@archive.org>"]
description = "Fatcat is an editable bibliographic database. This OpenAPI code-generated crate container HTTP API models, endpoints, and other auto-generated types useful for both client and server implementations of the catalog API."
@@ -11,7 +11,7 @@ license = "CC0-1.0"
[features]
default = ["client", "server"]
client = [
- "hyper", "hyper-openssl", "native-tls", "openssl", "url"
+ "hyper", "hyper-openssl", "hyper-tls", "native-tls", "openssl", "url"
]
server = [
"serde_ignored", "hyper", "regex", "percent-encoding", "url", "lazy_static"
@@ -20,34 +20,36 @@ conversion = ["frunk", "frunk_derives", "frunk_core", "frunk-enum-core", "frunk-
[target.'cfg(any(target_os = "macos", target_os = "windows", target_os = "ios"))'.dependencies]
native-tls = { version = "0.2", optional = true }
+hyper-tls = { version = "0.4", optional = true }
[target.'cfg(not(any(target_os = "macos", target_os = "windows", target_os = "ios")))'.dependencies]
-hyper-openssl = { version = "0.7.1", optional = true }
+hyper-openssl = { version = "0.8", optional = true }
openssl = {version = "0.10", optional = true }
[dependencies]
# Common
+async-trait = "0.1.24"
chrono = { version = "0.4", features = ["serde"] }
-futures = "0.1"
-swagger = "4.0"
+futures = "0.3"
+swagger = "5.0.0-alpha-1"
log = "0.4.0"
mime = "0.3"
-serde = { version = "1.0", features = ["derive"]}
+serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
# Crates included if required by the API definition
# Common between server and client features
-hyper = {version = "0.12", optional = true}
-serde_ignored = {version = "0.0.4", optional = true}
-url = {version = "1.5", optional = true}
+hyper = {version = "0.13", optional = true}
+serde_ignored = {version = "0.1.1", optional = true}
+url = {version = "2.1", optional = true}
# Client-specific
# Server, and client callback-specific
lazy_static = { version = "1.4", optional = true }
-percent-encoding = {version = "1.0.0", optional = true}
+percent-encoding = {version = "2.1.0", optional = true}
regex = {version = "1.3", optional = true}
# Conversion
@@ -59,13 +61,13 @@ frunk-enum-core = { version = "0.2.0", optional = true }
[dev-dependencies]
clap = "2.25"
-error-chain = "0.12"
-env_logger = "0.6"
-tokio = "0.1.17"
-uuid = {version = "0.7", features = ["serde", "v4"]}
+env_logger = "0.7"
+tokio = { version = "0.2", features = ["rt-threaded", "macros", "stream"] }
+native-tls = "0.2"
+tokio-tls = "0.3"
[target.'cfg(not(any(target_os = "macos", target_os = "windows", target_os = "ios")))'.dev-dependencies]
-tokio-openssl = "0.3"
+tokio-openssl = "0.4"
openssl = "0.10"
[[example]]