summaryrefslogtreecommitdiffstats
path: root/rust/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@archive.org>2020-06-13 16:16:29 -0700
committerBryan Newbold <bnewbold@archive.org>2020-06-13 16:16:29 -0700
commite480a92be5c74873e076aca5bd456f56a4fe5cee (patch)
tree153bd4990535963b3fc27eb535a472ac5030df8f /rust/Cargo.toml
parent68781c9a2e230c507b87d01780c79fd8f1033a1b (diff)
downloadfatcat-cli-e480a92be5c74873e076aca5bd456f56a4fe5cee.tar.gz
fatcat-cli-e480a92be5c74873e076aca5bd456f56a4fe5cee.zip
working cargo workspace config
Diffstat (limited to 'rust/Cargo.toml')
-rw-r--r--rust/Cargo.toml51
1 files changed, 0 insertions, 51 deletions
diff --git a/rust/Cargo.toml b/rust/Cargo.toml
index 21da1db..113e147 100644
--- a/rust/Cargo.toml
+++ b/rust/Cargo.toml
@@ -1,57 +1,6 @@
-[package]
-name = "fatcat"
-version = "0.3.1"
-edition = "2018"
-authors = ["Bryan Newbold <bnewbold@archive.org>"]
-description = "A scalable, versioned, API-oriented catalog for bibliographic entities and file metadata"
-homepage = "https://fatcat.wiki"
-repository = "https://github.com/internetarchive/fatcat"
-license = "AGPL-3.0-or-later"
-
[workspace]
members = ["fatcat-openapi", "fatcat-cli"]
-[dependencies]
-fatcat-openapi = {version = "*", path = "fatcat-openapi", features = ["server"] }
-diesel = { version = "1.3", features = ["postgres", "uuid", "serde_json", "chrono", "r2d2"] }
-diesel_migrations = "1.3"
-dotenv = "0.15"
-clap = "2"
-uuid = "0.6"
-log = { version = "*", features = ["max_level_info", "release_max_level_info"] }
-data-encoding = "2.1"
-regex = "1"
-lazy_static = "1.0"
-sha1 = { version = "0.6", features = ["std"] }
-macaroon = { git = "https://github.com/bnewbold/libmacaroon-rs", branch = "bnewbold-broken" }
-rand = "*"
-failure = "*"
-
-# API server
-chrono = { version = "0.4", features = ["serde"] }
-futures = "0.1"
-hyper = "0.10"
-iron = "0.6"
-iron-slog = "0.0.2"
-iron-test = "*"
-swagger = "0.7"
-slog = "^2.0"
-slog-term = "*"
-slog-async = "*"
-slog-stdlog = "*"
-slog-scope = "*"
-serde_json = "1.0"
-serde = "1.0"
-serde_derive = "1.0"
-serde_ignored = "0.0.4"
-sentry = { version = "^0.12", default-features = false, features = ["with_client_implementation", "with_backtrace", "with_panic", "with_log", "with_rust_info", "with_failure"] }
-cadence = "^0.16"
-
-# Command-line tools
-crossbeam-channel = "0.2"
-num_cpus = "1"
-env_logger = "*"
-
[profile.release]
lto = true
codegen-units = 1