summaryrefslogtreecommitdiffstats
path: root/fatcat-openapi/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@archive.org>2022-08-11 19:39:44 -0700
committerBryan Newbold <bnewbold@archive.org>2022-08-11 19:39:47 -0700
commitf2179cc9071c4e95c307f7506e764ada9f484052 (patch)
treeb51d83986e91fddb2ad245003c87407ecbdcc563 /fatcat-openapi/Cargo.toml
parent7392e457fae4d9f7b3dfa79dccfdaf23d6f9d1a5 (diff)
downloadfatcat-cli-f2179cc9071c4e95c307f7506e764ada9f484052.tar.gz
fatcat-cli-f2179cc9071c4e95c307f7506e764ada9f484052.zip
re-codegen fatcat-openapi module
this includes manual reconsiliation of cargo deps (Cargo.toml)
Diffstat (limited to 'fatcat-openapi/Cargo.toml')
-rw-r--r--fatcat-openapi/Cargo.toml13
1 files changed, 6 insertions, 7 deletions
diff --git a/fatcat-openapi/Cargo.toml b/fatcat-openapi/Cargo.toml
index 0595501..000796e 100644
--- a/fatcat-openapi/Cargo.toml
+++ b/fatcat-openapi/Cargo.toml
@@ -20,10 +20,10 @@ conversion = ["frunk", "frunk_derives", "frunk_core", "frunk-enum-core", "frunk-
[target.'cfg(any(target_os = "macos", target_os = "windows", target_os = "ios"))'.dependencies]
native-tls = { version = "0.2", optional = true }
-hyper-tls = { version = "0.4", optional = true }
+hyper-tls = { version = "0.5", optional = true }
[target.'cfg(not(any(target_os = "macos", target_os = "windows", target_os = "ios")))'.dependencies]
-hyper-openssl = { version = "0.8", optional = true }
+hyper-openssl = { version = "0.9", optional = true }
openssl = {version = "0.10", optional = true }
[dependencies]
@@ -31,7 +31,7 @@ openssl = {version = "0.10", optional = true }
async-trait = "0.1.24"
chrono = { version = "0.4", features = ["serde"] }
futures = "0.3"
-swagger = "5.0.2"
+swagger = { version = "6.1", features = ["serdejson", "server", "client", "tls", "tcp"] }
log = "0.4.0"
mime = "0.3"
@@ -41,7 +41,7 @@ serde_json = "1.0"
# Crates included if required by the API definition
# Common between server and client features
-hyper = {version = "0.13", optional = true}
+hyper = {version = "0.14", features = ["full"], optional = true}
serde_ignored = {version = "0.1.1", optional = true}
url = {version = "2.1", optional = true}
@@ -62,12 +62,11 @@ frunk-enum-core = { version = "0.2.0", optional = true }
[dev-dependencies]
clap = "2.25"
env_logger = "0.7"
-tokio = { version = "0.2", features = ["rt-threaded", "macros", "stream"] }
+tokio = { version = "1.14", features = ["full"] }
native-tls = "0.2"
-tokio-tls = "0.3"
[target.'cfg(not(any(target_os = "macos", target_os = "windows", target_os = "ios")))'.dev-dependencies]
-tokio-openssl = "0.4"
+tokio-openssl = "0.6"
openssl = "0.10"
[[example]]