diff options
author | Bryan Newbold <bnewbold@archive.org> | 2020-08-25 19:24:25 -0700 |
---|---|---|
committer | Bryan Newbold <bnewbold@archive.org> | 2020-08-25 19:24:25 -0700 |
commit | f77729e13a26dac9d1085cf07a1eb182b1a815e0 (patch) | |
tree | d7f30c442d9621fb6a9247d9f4cbf7c467c5b667 /Cargo.toml | |
parent | 52c8213c0889f0ff16ff48c83121fb41bad56ba7 (diff) | |
download | es-public-proxy-f77729e13a26dac9d1085cf07a1eb182b1a815e0.tar.gz es-public-proxy-f77729e13a26dac9d1085cf07a1eb182b1a815e0.zip |
use log/env_logger for logging
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 25 |
1 files changed, 24 insertions, 1 deletions
@@ -1,8 +1,15 @@ [package] name = "es-public-proxy" version = "0.1.0" -authors = ["Bryan Newbold <bnewbold@archive.org>"] edition = "2018" +authors = ["Bryan Newbold <bnewbold@robocracy.org>"] +license = "AGPL-3+" +#license-file = "LICENSE.AGPLv3.txt" +description = "simple proxy for exposing a read-only subset of elasticsearch API to the public internet" +readme = "README.md" +repository = "https://gitlab.com/bnewbold/es-public-proxy" +keywords = ["elasticsearch", "proxy"] +categories = ["command-line-utilities"] [dependencies] hyper = "0.13" @@ -12,3 +19,19 @@ serde = { version = "1.0", features = ["derive"] } serde_json = "1.0" serde_urlencoded = "0.5" toml = "0.4" +log = "0.4" +env_logger = "0.7" + +[profile.release] +lto = true +codegen-units = 1 + +[package.metadata.deb] +maintainer = "Bryan Newbold <bnewbold@robocracy.org>" +depends = "$auto" +section = "utility" +priority = "optional" +assets = [ + ["target/release/es-public-proxy", "usr/bin/", "755"], + ["es-public-proxy.1", "usr/share/man/man1/", "644"], +] |