diff options
author | Steve Langasek <vorlon@debian.org> | 2005-01-10 08:53:33 +0000 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:30 -0800 |
commit | e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch) | |
tree | abbf06041619e445f9d0b772b0d58132009d8234 /uri.txi | |
parent | f559c149c83da84d0b1c285f0298c84aec564af9 (diff) | |
parent | 8466d8cfa486fb30d1755c4261b781135083787b (diff) | |
download | slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip |
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low
* Non-maintainer upload.
* Add guile.init.local for use within the build dir, since otherwise we
have an (earlier unnoticed) circular build-dep due to a difference
between scm and guile.
slib (3a1-4.1) unstable; urgency=low
* Non-maintainer upload.
* Build-depend on guile-1.6 instead of scm, since the new version of
scm is wedged in unstable (closes: #281809).
slib (3a1-4) unstable; urgency=low
* Also check for expected creation on slibcat. (Closes: #240096)
slib (3a1-3) unstable; urgency=low
* Also check for /usr/share/guile/1.6/slib before installing for guile
1.6. (Closes: #239267)
slib (3a1-2) unstable; urgency=low
* Add format.scm back into slib until gnucash stops using it.
* Call guile-1.6 new-catalog (Closes: #238231)
slib (3a1-1) unstable; urgency=low
* New upstream release
* Remove Info section from doc-base file (Closes: #186950)
* Remove period from end of description (linda, lintian)
* html gen fixed upstream (Closes: #111778)
slib (2d4-2) unstable; urgency=low
* Fix url for upstream source (Closes: #144981)
* Fix typo in slib.texi (enquque->enqueue) (Closes: #147475)
* Add build depends.
slib (2d4-1) unstable; urgency=low
* New upstream.
slib (2d3-1) unstable; urgency=low
* New upstream.
* Remove texi2html call in debian/rules. Now done upstream. Add make
html instead.
* Changes to rules and doc-base to conform to upstream html gen
* Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'uri.txi')
-rw-r--r-- | uri.txi | 87 |
1 files changed, 85 insertions, 2 deletions
@@ -22,6 +22,11 @@ described in RFC 2396. Returns a Uniform Resource Identifier string from component arguments. @end defun +@defun uri:make-path path + +Returns a URI string combining the components of list @var{path}. +@end defun + @defun html:anchor name Returns a string which defines this location in the (HTML) file as @var{name}. The hypertext @samp{<A HREF="#@var{name}">} will link to this point. @@ -54,13 +59,19 @@ Returns a string specifying the search @var{prompt} of a document, for inclusion in the HEAD of the document (@pxref{HTML, head}). @end defun -@defun uri->tree uri-reference base-tree @dots{} +@defun uri->tree uri-reference base-tree + + +@defunx uri->tree uri-reference + Returns a list of 5 elements corresponding to the parts (@var{scheme} @var{authority} @var{path} @var{query} @var{fragment}) of string @var{uri-reference}. Elements corresponding to absent parts are #f. The @var{path} is a list of strings. If the first string is empty, -then the path is absolute; otherwise relative. +then the path is absolute; otherwise relative. The optional @var{base-tree} is a +tree as returned by @code{uri->tree}; and is used as the base address for relative +URIs. If the @var{authority} component is a @dfn{Server-based Naming Authority}, then it is a list of the @@ -76,6 +87,17 @@ string. @end example @end defun +@defun uri:split-fields txt chr + +Returns a list of @var{txt} split at each occurrence of @var{chr}. @var{chr} does not +appear in the returned list of strings. +@end defun + +@defun uri:decode-query query-string +Converts a @dfn{URI} encoded @var{query-string} to a query-alist. +@cindex URI +@end defun + @noindent @code{uric:} prefixes indicate procedures dealing with URI-components. @@ -93,3 +115,64 @@ Returns a copy of the string @var{uri-component} in which each @samp{%} escaped characters in @var{uri-component} is replaced with the character it encodes. This routine is useful for showing URI contents on error pages. @end defun + +@defun uri:path->keys path-list ptypes +@var{path-list} is a path-list as returned by @code{uri:split-fields}. @code{uri:path->keys} +returns a list of items returned by @code{uri:decode-path}, coerced +to types @var{ptypes}. +@end defun +@subheading File-system Locators and Predicates + + +@defun path->uri path +Returns a URI-string for @var{path} on the local host. +@end defun + +@defun absolute-uri? str +Returns #t if @var{str} is an absolute-URI as indicated by a +syntactically valid (per RFC 2396) @dfn{scheme}; otherwise returns +@cindex scheme +#f. +@end defun + +@defun absolute-path? file-name +Returns #t if @var{file-name} is a fully specified pathname (does not +depend on the current working directory); otherwise returns #f. +@end defun + +@defun null-directory? str +Returns #t if changing directory to @var{str} would leave the current +directory unchanged; otherwise returns #f. +@end defun + +@defun glob-pattern? str +Returns #t if the string @var{str} contains characters used for +specifying glob patterns, namely @samp{*}, @samp{?}, or @samp{[}. +@end defun +@noindent +Before RFC 2396, the @dfn{File Transfer Protocol} (FTP) served a +@cindex File Transfer Protocol +similar purpose. + + +@defun parse-ftp-address uri + +Returns a list of the decoded FTP @var{uri}; or #f if indecipherable. FTP +@dfn{Uniform Resource Locator}, @dfn{ange-ftp}, and @dfn{getit} +@cindex Uniform Resource Locator +@cindex ange-ftp +@cindex getit +formats are handled. The returned list has four elements which are +strings or #f: + +@enumerate 0 +@item +username +@item +password +@item +remote-site +@item +remote-directory +@end enumerate +@end defun |