diff options
author | Thomas Bushnell, BSG <tb@debian.org> | 2005-11-02 14:55:21 -0800 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:32 -0800 |
commit | 34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch) | |
tree | 1189d06a81277bcf8539b0260a69a19f6038effb /uri.scm | |
parent | 611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff) | |
parent | 5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff) | |
download | slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip |
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low
* New upstream release.
* Acknowledge NMU. (Closes: #281809)
* Makefile: Don't hack Makefile; use rules instead.
* debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML.
* debian/rules (clean): Clean more stuff here.
* Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead,
specify directly that the texi2html invocation produces that file.
* debian/rules (binary-indep): Find web files in slib subdir.
* debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'uri.scm')
-rw-r--r-- | uri.scm | 16 |
1 files changed, 8 insertions, 8 deletions
@@ -207,10 +207,10 @@ (if idx-at (substring authority (+ 1 idx-at) (string-length authority)) authority)) - (idx-: (string-index hostport #\:)) - (host (if idx-: (substring hostport 0 idx-:) hostport)) - (port (and idx-: - (substring hostport (+ 1 idx-:) (string-length hostport))))) + (cdx (string-index hostport #\:)) + (host (if cdx (substring hostport 0 cdx) hostport)) + (port (and cdx + (substring hostport (+ 1 cdx) (string-length hostport))))) (if (or userinfo port) (list userinfo host (or (string->number port) port)) host))) @@ -269,10 +269,10 @@ uri))) (if front (let* ((len (string-length front)) - (idx-: (string-index front #\:)) - (scheme (and idx-: (substring front 0 idx-:))) - (path (if idx-: - (substring front (+ 1 idx-:) len) + (cdx (string-index front #\:)) + (scheme (and cdx (substring front 0 cdx))) + (path (if cdx + (substring front (+ 1 cdx) len) front))) (cond ((eqv? 0 (substring? "//" path)) (set! len (string-length path)) |