diff options
author | Steve Langasek <vorlon@debian.org> | 2005-01-10 08:53:33 +0000 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:30 -0800 |
commit | e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch) | |
tree | abbf06041619e445f9d0b772b0d58132009d8234 /trace.scm | |
parent | f559c149c83da84d0b1c285f0298c84aec564af9 (diff) | |
parent | 8466d8cfa486fb30d1755c4261b781135083787b (diff) | |
download | slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip |
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low
* Non-maintainer upload.
* Add guile.init.local for use within the build dir, since otherwise we
have an (earlier unnoticed) circular build-dep due to a difference
between scm and guile.
slib (3a1-4.1) unstable; urgency=low
* Non-maintainer upload.
* Build-depend on guile-1.6 instead of scm, since the new version of
scm is wedged in unstable (closes: #281809).
slib (3a1-4) unstable; urgency=low
* Also check for expected creation on slibcat. (Closes: #240096)
slib (3a1-3) unstable; urgency=low
* Also check for /usr/share/guile/1.6/slib before installing for guile
1.6. (Closes: #239267)
slib (3a1-2) unstable; urgency=low
* Add format.scm back into slib until gnucash stops using it.
* Call guile-1.6 new-catalog (Closes: #238231)
slib (3a1-1) unstable; urgency=low
* New upstream release
* Remove Info section from doc-base file (Closes: #186950)
* Remove period from end of description (linda, lintian)
* html gen fixed upstream (Closes: #111778)
slib (2d4-2) unstable; urgency=low
* Fix url for upstream source (Closes: #144981)
* Fix typo in slib.texi (enquque->enqueue) (Closes: #147475)
* Add build depends.
slib (2d4-1) unstable; urgency=low
* New upstream.
slib (2d3-1) unstable; urgency=low
* New upstream.
* Remove texi2html call in debian/rules. Now done upstream. Add make
html instead.
* Changes to rules and doc-base to conform to upstream html gen
* Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'trace.scm')
-rw-r--r-- | trace.scm | 24 |
1 files changed, 13 insertions, 11 deletions
@@ -1,5 +1,5 @@ -;;;; "trace.scm" Utility macros for tracing in Scheme. -;;; Copyright (C) 1991, 1992, 1993, 1994, 1995, 1999, 2000 Aubrey Jaffer +;;;; "trace.scm" Utility functions and macros for tracing in Scheme. +;;; Copyright (C) 1991, 1992, 1993, 1994, 1995, 1999, 2000, 2003 Aubrey Jaffer ; ;Permission to copy this software, to modify it, to redistribute it, ;to distribute modified versions, and to use it for any purpose is @@ -8,7 +8,7 @@ ;1. Any copy made of this software must include this copyright notice ;in full. ; -;2. I have made no warrantee or representation that the operation of +;2. I have made no warranty or representation that the operation of ;this software will be error-free, and I am under no obligation to ;provide any services, by way of maintenance, update, or otherwise. ; @@ -18,8 +18,11 @@ ;each case. (require 'qp) ;for the qp printer. +(require 'alist) + (define trace:indent 0) (define debug:call-stack '()) ;keeps track of call stack. +;@ (define debug:max-count 5) ;;Formats for call-stack elements: @@ -27,6 +30,7 @@ ;; (procedure-count name) ;for debug:stack procedure ;;Traced functions also stack. +;@ (define print-call-stack (let ((car car) (null? null?) (current-error-port current-error-port) (qpn qpn) (for-each for-each)) @@ -121,7 +125,7 @@ ;;; The reason I use a symbol for debug:untrace-object is so that ;;; functions can still be untraced if this file is read in twice. - +;@ (define (untracef function) (set! trace:indent 0) (function 'debug:untrace-object)) @@ -130,7 +134,6 @@ ;;; niceties like keeping track of traced functions and dealing with ;;; redefinition. -(require 'alist) (define trace:adder (alist-associator eq?)) (define trace:deler (alist-remover eq?)) @@ -190,13 +193,14 @@ (set! *stacked-procedures* (trace:deler *stacked-procedures* sym)) (finish p))) (else fun))) - +;@ (define (tracef . args) (apply debug:trace-procedure 'trace args)) +;@ (define (trackf . args) (apply debug:trace-procedure 'track args)) +;@ (define (stackf . args) (apply debug:trace-procedure 'stack args)) - ;;;; Finally, the macros trace and untrace - +;@ (defmacro trace xs (if (null? xs) `(begin (set! trace:indent 0) @@ -222,7 +226,7 @@ (map car *stacked-procedures*)) `(begin ,@(map (lambda (x) `(set! ,x (trace:trace-procedure 'stack ,x ',x))) xs)))) - +;@ (defmacro untrace xs (if (null? xs) (slib:eval @@ -232,7 +236,6 @@ '',(map car *traced-procedures*))) `(begin ,@(map (lambda (x) `(set! ,x (trace:untrace-procedure ,x ',x))) xs)))) - (defmacro untrack xs (if (null? xs) (slib:eval @@ -242,7 +245,6 @@ '',(map car *tracked-procedures*))) `(begin ,@(map (lambda (x) `(set! ,x (track:untrack-procedure ,x ',x))) xs)))) - (defmacro unstack xs (if (null? xs) (slib:eval |