diff options
author | Steve Langasek <vorlon@debian.org> | 2005-01-10 08:53:33 +0000 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:30 -0800 |
commit | e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch) | |
tree | abbf06041619e445f9d0b772b0d58132009d8234 /ratize.scm | |
parent | f559c149c83da84d0b1c285f0298c84aec564af9 (diff) | |
parent | 8466d8cfa486fb30d1755c4261b781135083787b (diff) | |
download | slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip |
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low
* Non-maintainer upload.
* Add guile.init.local for use within the build dir, since otherwise we
have an (earlier unnoticed) circular build-dep due to a difference
between scm and guile.
slib (3a1-4.1) unstable; urgency=low
* Non-maintainer upload.
* Build-depend on guile-1.6 instead of scm, since the new version of
scm is wedged in unstable (closes: #281809).
slib (3a1-4) unstable; urgency=low
* Also check for expected creation on slibcat. (Closes: #240096)
slib (3a1-3) unstable; urgency=low
* Also check for /usr/share/guile/1.6/slib before installing for guile
1.6. (Closes: #239267)
slib (3a1-2) unstable; urgency=low
* Add format.scm back into slib until gnucash stops using it.
* Call guile-1.6 new-catalog (Closes: #238231)
slib (3a1-1) unstable; urgency=low
* New upstream release
* Remove Info section from doc-base file (Closes: #186950)
* Remove period from end of description (linda, lintian)
* html gen fixed upstream (Closes: #111778)
slib (2d4-2) unstable; urgency=low
* Fix url for upstream source (Closes: #144981)
* Fix typo in slib.texi (enquque->enqueue) (Closes: #147475)
* Add build depends.
slib (2d4-1) unstable; urgency=low
* New upstream.
slib (2d3-1) unstable; urgency=low
* New upstream.
* Remove texi2html call in debian/rules. Now done upstream. Add make
html instead.
* Changes to rules and doc-base to conform to upstream html gen
* Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'ratize.scm')
-rw-r--r-- | ratize.scm | 43 |
1 files changed, 41 insertions, 2 deletions
@@ -1,5 +1,46 @@ ;;;; "ratize.scm" Find simplest number ratios +;;@code{(require 'rationalize)} +;;@ftindex rationalize + +;;The procedure @dfn{rationalize} is interesting because most programming +;;languages do not provide anything analogous to it. Thanks to Alan +;;Bawden for contributing this algorithm. + +;;@body +;;Computes the correct result for exact arguments (provided the +;;implementation supports exact rational numbers of unlimited precision); +;;and produces a reasonable answer for inexact arguments when inexact +;;arithmetic is implemented using floating-point. +;; +(define (rationalize x e) (apply / (find-ratio x e))) + +;;@code{Rationalize} has limited use in implementations lacking exact +;;(non-integer) rational numbers. The following procedures return a list +;;of the numerator and denominator. + +;;@body +;;@0 returns the list of the @emph{simplest} +;;numerator and denominator whose quotient differs from @1 by no more +;;than @2. +;; +;;@format +;;@t{(find-ratio 3/97 .0001) @result{} (3 97) +;;(find-ratio 3/97 .001) @result{} (1 32) +;;} +;;@end format +(define (find-ratio x e) (find-ratio-between (- x e) (+ x e))) + + +;;@body +;;@0 returns the list of the @emph{simplest} +;;numerator and denominator between @1 and @2. +;; +;;@format +;;@t{(find-ratio-between 2/7 3/5) @result{} (1 2) +;;(find-ratio-between -3/5 -2/7) @result{} (-1 2) +;;} +;;@end format (define (find-ratio-between x y) (define (sr x y) (let ((fx (inexact->exact (floor x))) (fy (inexact->exact (floor y)))) @@ -13,5 +54,3 @@ ((negative? y) (let ((rat (sr (- y) (- x)))) (list (- (car rat)) (cadr rat)))) (else '(0 1)))) -(define (find-ratio x e) (find-ratio-between (- x e) (+ x e))) -(define (rationalize x e) (apply / (find-ratio x e))) |