diff options
author | Steve Langasek <vorlon@debian.org> | 2005-01-10 08:53:33 +0000 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:30 -0800 |
commit | e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch) | |
tree | abbf06041619e445f9d0b772b0d58132009d8234 /random.txi | |
parent | f559c149c83da84d0b1c285f0298c84aec564af9 (diff) | |
parent | 8466d8cfa486fb30d1755c4261b781135083787b (diff) | |
download | slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip |
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low
* Non-maintainer upload.
* Add guile.init.local for use within the build dir, since otherwise we
have an (earlier unnoticed) circular build-dep due to a difference
between scm and guile.
slib (3a1-4.1) unstable; urgency=low
* Non-maintainer upload.
* Build-depend on guile-1.6 instead of scm, since the new version of
scm is wedged in unstable (closes: #281809).
slib (3a1-4) unstable; urgency=low
* Also check for expected creation on slibcat. (Closes: #240096)
slib (3a1-3) unstable; urgency=low
* Also check for /usr/share/guile/1.6/slib before installing for guile
1.6. (Closes: #239267)
slib (3a1-2) unstable; urgency=low
* Add format.scm back into slib until gnucash stops using it.
* Call guile-1.6 new-catalog (Closes: #238231)
slib (3a1-1) unstable; urgency=low
* New upstream release
* Remove Info section from doc-base file (Closes: #186950)
* Remove period from end of description (linda, lintian)
* html gen fixed upstream (Closes: #111778)
slib (2d4-2) unstable; urgency=low
* Fix url for upstream source (Closes: #144981)
* Fix typo in slib.texi (enquque->enqueue) (Closes: #147475)
* Add build depends.
slib (2d4-1) unstable; urgency=low
* New upstream.
slib (2d3-1) unstable; urgency=low
* New upstream.
* Remove texi2html call in debian/rules. Now done upstream. Add make
html instead.
* Changes to rules and doc-base to conform to upstream html gen
* Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'random.txi')
-rw-r--r-- | random.txi | 26 |
1 files changed, 17 insertions, 9 deletions
@@ -1,17 +1,23 @@ +@code{(require 'random)} +@ftindex random -@defun random n -@defunx random n state -Accepts a positive integer or real @var{n} and returns a number of the -same type between zero (inclusive) and @var{n} (exclusive). The values -returned by @code{random} are uniformly distributed from 0 to @var{n}. + +@defun random n state + + +@defunx random n + +@var{n} must be an exact positive integer. @code{random} returns an exact integer +between zero (inclusive) and @var{n} (exclusive). The values returned by +@code{random} are uniformly distributed from 0 to @var{n}. The optional argument @var{state} must be of the type returned by -@code{(seed->random-state)} or @code{(make-random-state)}. It defaults -to the value of the variable @code{*random-state*}. This object is used -to maintain the state of the pseudo-random-number generator and is -altered as a side effect of calls to @code{random}. +@code{(seed->random-state)} or @code{(make-random-state)}. It +defaults to the value of the variable @code{*random-state*}. This +object is used to maintain the state of the pseudo-random-number +generator and is altered as a side effect of calls to @code{random}. @end defun @defvar *random-state* Holds a data structure that encodes the internal state of the @@ -53,3 +59,5 @@ Scheme object; the first 50 characters of its printed representation will be used as the seed. Otherwise the value of @code{*random-state*} is used as the seed. @end defun + + |