diff options
author | Thomas Bushnell, BSG <tb@debian.org> | 2005-11-02 14:55:21 -0800 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:32 -0800 |
commit | 34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch) | |
tree | 1189d06a81277bcf8539b0260a69a19f6038effb /random.txi | |
parent | 611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff) | |
parent | 5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff) | |
download | slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip |
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low
* New upstream release.
* Acknowledge NMU. (Closes: #281809)
* Makefile: Don't hack Makefile; use rules instead.
* debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML.
* debian/rules (clean): Clean more stuff here.
* Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead,
specify directly that the texi2html invocation produces that file.
* debian/rules (binary-indep): Find web files in slib subdir.
* debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'random.txi')
-rw-r--r-- | random.txi | 4 |
1 files changed, 4 insertions, 0 deletions
@@ -19,6 +19,7 @@ defaults to the value of the variable @code{*random-state*}. This object is used to maintain the state of the pseudo-random-number generator and is altered as a side effect of calls to @code{random}. @end defun + @defvar *random-state* Holds a data structure that encodes the internal state of the random-number generator that @code{random} uses by default. The nature @@ -37,6 +38,7 @@ Returns a new copy of argument @var{state}. Returns a new copy of @code{*random-state*}. @end defun + @defun seed->random-state seed Returns a new object of type suitable for use as the value of the @@ -48,6 +50,7 @@ Calling @code{seed->random-state} with unequal arguments will nearly always return unequal states. @end defun + @defun make-random-state @@ -61,3 +64,4 @@ is used as the seed. @end defun + |