diff options
author | Steve Langasek <vorlon@debian.org> | 2005-01-10 08:53:33 +0000 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:30 -0800 |
commit | e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch) | |
tree | abbf06041619e445f9d0b772b0d58132009d8234 /queue.scm | |
parent | f559c149c83da84d0b1c285f0298c84aec564af9 (diff) | |
parent | 8466d8cfa486fb30d1755c4261b781135083787b (diff) | |
download | slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip |
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low
* Non-maintainer upload.
* Add guile.init.local for use within the build dir, since otherwise we
have an (earlier unnoticed) circular build-dep due to a difference
between scm and guile.
slib (3a1-4.1) unstable; urgency=low
* Non-maintainer upload.
* Build-depend on guile-1.6 instead of scm, since the new version of
scm is wedged in unstable (closes: #281809).
slib (3a1-4) unstable; urgency=low
* Also check for expected creation on slibcat. (Closes: #240096)
slib (3a1-3) unstable; urgency=low
* Also check for /usr/share/guile/1.6/slib before installing for guile
1.6. (Closes: #239267)
slib (3a1-2) unstable; urgency=low
* Add format.scm back into slib until gnucash stops using it.
* Call guile-1.6 new-catalog (Closes: #238231)
slib (3a1-1) unstable; urgency=low
* New upstream release
* Remove Info section from doc-base file (Closes: #186950)
* Remove period from end of description (linda, lintian)
* html gen fixed upstream (Closes: #111778)
slib (2d4-2) unstable; urgency=low
* Fix url for upstream source (Closes: #144981)
* Fix typo in slib.texi (enquque->enqueue) (Closes: #147475)
* Add build depends.
slib (2d4-1) unstable; urgency=low
* New upstream.
slib (2d3-1) unstable; urgency=low
* New upstream.
* Remove texi2html call in debian/rules. Now done upstream. Add make
html instead.
* Changes to rules and doc-base to conform to upstream html gen
* Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'queue.scm')
-rw-r--r-- | queue.scm | 77 |
1 files changed, 57 insertions, 20 deletions
@@ -1,21 +1,33 @@ -; "queue.scm" Queues/Stacks for Scheme -; Written by Andrew Wilcox (awilcox@astro.psu.edu) on April 1, 1992. -; -; This code is in the public domain. +;; "queue.scm" Queues/Stacks for Scheme +;; Written by Andrew Wilcox (awilcox@astro.psu.edu) on April 1, 1992. +;; +;; This code is in the public domain. (require 'record) -; Elements in a queue are stored in a list. The last pair in the list -; is stored in the queue type so that datums can be added in constant -; time. +;;@code{(require 'queue)} +;;@ftindex queue +;; +;;A @dfn{queue} is a list where elements can be added to both the front +;;and rear, and removed from the front (i.e., they are what are often +;;called @dfn{dequeues}). A queue may also be used like a stack. + +;; Elements in a queue are stored in a list. The last pair in the list +;; is stored in the queue type so that datums can be added in constant +;; time. (define queue:record-type (make-record-type "queue" '(first-pair last-pair))) + +;;@args +;;Returns a new, empty queue. (define make-queue (let ((construct-queue (record-constructor queue:record-type))) (lambda () (construct-queue '() '())))) +;;@args obj +;;Returns @code{#t} if @var{obj} is a queue. (define queue? (record-predicate queue:record-type)) (define queue:first-pair (record-accessor queue:record-type @@ -27,21 +39,13 @@ (define queue:set-last-pair! (record-modifier queue:record-type 'last-pair)) +;;@body +;;Returns @code{#t} if the queue @var{q} is empty. (define (queue-empty? q) (null? (queue:first-pair q))) -(define (queue-front q) - (let ((first-pair (queue:first-pair q))) - (if (null? first-pair) - (slib:error "queue is empty" q)) - (car first-pair))) - -(define (queue-rear q) - (let ((last-pair (queue:last-pair q))) - (if (null? last-pair) - (slib:error "queue is empty" q)) - (car last-pair))) - +;;@body +;;Adds @var{datum} to the front of queue @var{q}. (define (queue-push! q datum) (let* ((old-first-pair (queue:first-pair q)) (new-first-pair (cons datum old-first-pair))) @@ -50,6 +54,8 @@ (queue:set-last-pair! q new-first-pair))) q) +;;@body +;;Adds @var{datum} to the rear of queue @var{q}. (define (enqueue! q datum) (let ((new-pair (cons datum '()))) (cond ((null? (queue:first-pair q)) @@ -59,6 +65,11 @@ (queue:set-last-pair! q new-pair)) q) +;;@body +;;@deffnx {Procedure} queue-pop! q +;;Both of these procedures remove and return the datum at the front of +;;the queue. @code{queue-pop!} is used to suggest that the queue is +;;being used like a stack. (define (dequeue! q) (let ((first-pair (queue:first-pair q))) (if (null? first-pair) @@ -68,5 +79,31 @@ (if (null? first-cdr) (queue:set-last-pair! q '())) (car first-pair)))) - (define queue-pop! dequeue!) + +;;@ All of the following functions raise an error if the queue @var{q} +;;is empty. + +;;@body +;;Removes and returns (the list) of all contents of queue @var{q}. +(define (dequeue-all! q) + (let ((lst (queue:first-pair q))) + (queue:set-first-pair! q '()) + (queue:set-last-pair! q '()) + lst)) + +;;@body +;;Returns the datum at the front of the queue @var{q}. +(define (queue-front q) + (let ((first-pair (queue:first-pair q))) + (if (null? first-pair) + (slib:error "queue is empty" q)) + (car first-pair))) + +;;@body +;;Returns the datum at the rear of the queue @var{q}. +(define (queue-rear q) + (let ((last-pair (queue:last-pair q))) + (if (null? last-pair) + (slib:error "queue is empty" q)) + (car last-pair))) |