diff options
author | Thomas Bushnell, BSG <tb@debian.org> | 2005-11-02 14:55:21 -0800 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:32 -0800 |
commit | 34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch) | |
tree | 1189d06a81277bcf8539b0260a69a19f6038effb /ppfile.scm | |
parent | 611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff) | |
parent | 5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff) | |
download | slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip |
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low
* New upstream release.
* Acknowledge NMU. (Closes: #281809)
* Makefile: Don't hack Makefile; use rules instead.
* debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML.
* debian/rules (clean): Clean more stuff here.
* Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead,
specify directly that the texi2html invocation produces that file.
* debian/rules (binary-indep): Find web files in slib subdir.
* debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'ppfile.scm')
-rw-r--r-- | ppfile.scm | 7 |
1 files changed, 3 insertions, 4 deletions
@@ -33,8 +33,7 @@ (fun outport) (call-with-output-file outport fun)))) (lambda (export) - (let ((old-load-pathname *load-pathname*)) - (set! *load-pathname* inport) + (with-load-pathname inport (letrec ((lp (lambda (c) (cond ((eof-object? c)) ((char-whitespace? c) @@ -62,8 +61,8 @@ (read-char port) (set! c (peek-char port)))) (lp c)))))))) - (lp (peek-char port))) - (set! *load-pathname* old-load-pathname))))))) + (lambda () + (lp (peek-char port)))))))))) ;@ (define (pprint-file ifile . optarg) (pprint-filter-file ifile |