diff options
author | Steve Langasek <vorlon@debian.org> | 2005-01-10 08:53:33 +0000 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:30 -0800 |
commit | e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch) | |
tree | abbf06041619e445f9d0b772b0d58132009d8234 /lineio.scm | |
parent | f559c149c83da84d0b1c285f0298c84aec564af9 (diff) | |
parent | 8466d8cfa486fb30d1755c4261b781135083787b (diff) | |
download | slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip |
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low
* Non-maintainer upload.
* Add guile.init.local for use within the build dir, since otherwise we
have an (earlier unnoticed) circular build-dep due to a difference
between scm and guile.
slib (3a1-4.1) unstable; urgency=low
* Non-maintainer upload.
* Build-depend on guile-1.6 instead of scm, since the new version of
scm is wedged in unstable (closes: #281809).
slib (3a1-4) unstable; urgency=low
* Also check for expected creation on slibcat. (Closes: #240096)
slib (3a1-3) unstable; urgency=low
* Also check for /usr/share/guile/1.6/slib before installing for guile
1.6. (Closes: #239267)
slib (3a1-2) unstable; urgency=low
* Add format.scm back into slib until gnucash stops using it.
* Call guile-1.6 new-catalog (Closes: #238231)
slib (3a1-1) unstable; urgency=low
* New upstream release
* Remove Info section from doc-base file (Closes: #186950)
* Remove period from end of description (linda, lintian)
* html gen fixed upstream (Closes: #111778)
slib (2d4-2) unstable; urgency=low
* Fix url for upstream source (Closes: #144981)
* Fix typo in slib.texi (enquque->enqueue) (Closes: #147475)
* Add build depends.
slib (2d4-1) unstable; urgency=low
* New upstream.
slib (2d3-1) unstable; urgency=low
* New upstream.
* Remove texi2html call in debian/rules. Now done upstream. Add make
html instead.
* Changes to rules and doc-base to conform to upstream html gen
* Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'lineio.scm')
-rw-r--r-- | lineio.scm | 34 |
1 files changed, 20 insertions, 14 deletions
@@ -8,7 +8,7 @@ ;1. Any copy made of this software must include this copyright notice ;in full. ; -;2. I have made no warrantee or representation that the operation of +;2. I have made no warranty or representation that the operation of ;this software will be error-free, and I am under no obligation to ;provide any services, by way of maintenance, update, or otherwise. ; @@ -17,6 +17,7 @@ ;promotional, or sales literature without prior written consent in ;each case. +(require-if 'compiling 'filename) ;;@args ;;@args port @@ -63,20 +64,25 @@ ;;Writes @1 followed by a newline to the given @var{port} and returns ;;an unspecified value. The @var{Port} argument may be omitted, in ;;which case it defaults to the value returned by -;;@code{current-input-port}.@refill +;;@code{current-input-port}. (define (write-line str . port) (apply display str port) (apply newline port)) -;;@args path -;;@args path port -;;Displays the contents of the file named by @1 to @var{port}. The -;;@var{port} argument may be ommited, in which case it defaults to the -;;value returned by @code{current-output-port}. -(define (display-file path . port) - (set! port (if (null? port) (current-output-port) (car port))) - (call-with-input-file path - (lambda (inport) - (do ((line (read-line inport) (read-line inport))) - ((eof-object? line)) - (write-line line port))))) +;;@args command tmp +;;@args command +;;@1 must be a string. The string @2, if supplied, is a path to use as +;;a temporary file. @0 calls @code{system} with @1 as argument, +;;redirecting stdout to file @2. @0 returns a string containing the +;;first line of output from @2. +(define (system->line command . tmp) + (require 'filename) + (cond ((null? tmp) + (call-with-tmpnam + (lambda (tmp) (system->line command tmp)))) + (else + (set! tmp (car tmp)) + (and (zero? (system (string-append command " > " tmp))) + (file-exists? tmp) + (let ((line (call-with-input-file tmp read-line))) + (if (eof-object? line) "" line)))))) |