diff options
author | Thomas Bushnell, BSG <tb@debian.org> | 2005-11-02 14:55:21 -0800 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:32 -0800 |
commit | 34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch) | |
tree | 1189d06a81277bcf8539b0260a69a19f6038effb /determ.txi | |
parent | 611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff) | |
parent | 5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff) | |
download | slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip |
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low
* New upstream release.
* Acknowledge NMU. (Closes: #281809)
* Makefile: Don't hack Makefile; use rules instead.
* debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML.
* debian/rules (clean): Clean more stuff here.
* Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead,
specify directly that the texi2html invocation produces that file.
* debian/rules (binary-indep): Find web files in slib subdir.
* debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'determ.txi')
-rw-r--r-- | determ.txi | 8 |
1 files changed, 7 insertions, 1 deletions
@@ -3,7 +3,7 @@ @noindent A Matrix can be either a list of lists (rows) or an array. -As with linear-algebra texts, this package uses 1-based coordinates. +Unlike linear-algebra texts, this package uses 0-based coordinates. @defun matrix->lists matrix @@ -11,11 +11,13 @@ As with linear-algebra texts, this package uses 1-based coordinates. Returns the list-of-lists form of @var{matrix}. @end defun + @defun matrix->array matrix Returns the (ones-based) array form of @var{matrix}. @end defun + @defun determinant matrix @var{matrix} must be a square matrix. @@ -28,20 +30,24 @@ Returns the (ones-based) array form of @var{matrix}. @end example @end defun + @defun transpose matrix Returns a copy of @var{matrix} flipped over the diagonal containing the 1,1 element. @end defun + @defun matrix:product m1 m2 Returns the product of matrices @var{m1} and @var{m2}. @end defun + @defun matrix:inverse matrix @var{matrix} must be a square matrix. If @var{matrix} is singlar, then @code{matrix:inverse} returns #f; otherwise @code{matrix:inverse} returns the @code{matrix:product} inverse of @var{matrix}. @end defun + |