diff options
author | Thomas Bushnell, BSG <tb@debian.org> | 2007-12-28 16:25:32 -0800 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:39 -0800 |
commit | d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e (patch) | |
tree | b20b8bc02e854c4c86d39ee22a0638a8b06e01af /array.txi | |
parent | edd1ebef3ad774e7cbcc2f5918d555bfb0b44091 (diff) | |
parent | 64f037d91e0c9296dcaef9a0ff3eb33b19a2ed34 (diff) | |
download | slib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.tar.gz slib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.zip |
Import Debian changes 3a5-1debian/3a5-1
slib (3a5-1) unstable; urgency=low
* New upstream release.
* slib.texi (Library Catalogs): Repeat change from 3a3-3.
* Makefile: Repeat $(htmldir)slib_toc.html changes from 3a2-1.
* guile.init: (library-vicinity): Repeat change from 3a4-2.
* debian/rules (binary-indep): Don't hide .init files in a separate
subdirectory, thus conforming better to the usual slib practice. Put a
symlink in place to ease transitions. (Closes: #407370).
Diffstat (limited to 'array.txi')
-rw-r--r-- | array.txi | 140 |
1 files changed, 40 insertions, 100 deletions
@@ -203,171 +203,111 @@ uniform-array type is supported by the implementation, then it is returned; defaulting to the next larger precision type; resorting finally to vector. - -@defun a:floc128b z - - -@defunx a:floc128b +@defun A:floC128b z +@defunx A:floC128b Returns an inexact 128.bit flonum complex uniform-array prototype. @end defun - -@defun a:floc64b z - - -@defunx a:floc64b +@defun A:floC64b z +@defunx A:floC64b Returns an inexact 64.bit flonum complex uniform-array prototype. @end defun - -@defun a:floc32b z - - -@defunx a:floc32b +@defun A:floC32b z +@defunx A:floC32b Returns an inexact 32.bit flonum complex uniform-array prototype. @end defun - -@defun a:floc16b z - - -@defunx a:floc16b +@defun A:floC16b z +@defunx A:floC16b Returns an inexact 16.bit flonum complex uniform-array prototype. @end defun - -@defun a:flor128b z - - -@defunx a:flor128b +@defun A:floR128b x +@defunx A:floR128b Returns an inexact 128.bit flonum real uniform-array prototype. @end defun - -@defun a:flor64b z - - -@defunx a:flor64b +@defun A:floR64b x +@defunx A:floR64b Returns an inexact 64.bit flonum real uniform-array prototype. @end defun - -@defun a:flor32b z - - -@defunx a:flor32b +@defun A:floR32b x +@defunx A:floR32b Returns an inexact 32.bit flonum real uniform-array prototype. @end defun - -@defun a:flor16b z - - -@defunx a:flor16b +@defun A:floR16b x +@defunx A:floR16b Returns an inexact 16.bit flonum real uniform-array prototype. @end defun - -@defun a:flor128b z - - -@defunx a:flor128b +@defun A:floR128d q +@defunx A:floR128d Returns an exact 128.bit decimal flonum rational uniform-array prototype. @end defun - -@defun a:flor64b z - - -@defunx a:flor64b +@defun A:floR64d q +@defunx A:floR64d Returns an exact 64.bit decimal flonum rational uniform-array prototype. @end defun - -@defun a:flor32b z - - -@defunx a:flor32b +@defun A:floR32d q +@defunx A:floR32d Returns an exact 32.bit decimal flonum rational uniform-array prototype. @end defun - -@defun a:fixz64b n - - -@defunx a:fixz64b +@defun A:fixZ64b n +@defunx A:fixZ64b Returns an exact binary fixnum uniform-array prototype with at least 64 bits of precision. @end defun - -@defun a:fixz32b n - - -@defunx a:fixz32b +@defun A:fixZ32b n +@defunx A:fixZ32b Returns an exact binary fixnum uniform-array prototype with at least 32 bits of precision. @end defun - -@defun a:fixz16b n - - -@defunx a:fixz16b +@defun A:fixZ16b n +@defunx A:fixZ16b Returns an exact binary fixnum uniform-array prototype with at least 16 bits of precision. @end defun - -@defun a:fixz8b n - - -@defunx a:fixz8b +@defun A:fixZ8b n +@defunx A:fixZ8b Returns an exact binary fixnum uniform-array prototype with at least 8 bits of precision. @end defun - -@defun a:fixn64b k - - -@defunx a:fixn64b +@defun A:fixN64b k +@defunx A:fixN64b Returns an exact non-negative binary fixnum uniform-array prototype with at least 64 bits of precision. @end defun - -@defun a:fixn32b k - - -@defunx a:fixn32b +@defun A:fixN32b k +@defunx A:fixN32b Returns an exact non-negative binary fixnum uniform-array prototype with at least 32 bits of precision. @end defun - -@defun a:fixn16b k - - -@defunx a:fixn16b +@defun A:fixN16b k +@defunx A:fixN16b Returns an exact non-negative binary fixnum uniform-array prototype with at least 16 bits of precision. @end defun - -@defun a:fixn8b k - - -@defunx a:fixn8b +@defun A:fixN8b k +@defunx A:fixN8b Returns an exact non-negative binary fixnum uniform-array prototype with at least 8 bits of precision. @end defun - -@defun a:bool bool - - -@defunx a:bool +@defun A:bool bool +@defunx A:bool Returns a boolean uniform-array prototype. @end defun |