diff options
author | Thomas Bushnell, BSG <tb@debian.org> | 2005-11-02 14:55:21 -0800 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:32 -0800 |
commit | 34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch) | |
tree | 1189d06a81277bcf8539b0260a69a19f6038effb /alist.txi | |
parent | 611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff) | |
parent | 5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff) | |
download | slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip |
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low
* New upstream release.
* Acknowledge NMU. (Closes: #281809)
* Makefile: Don't hack Makefile; use rules instead.
* debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML.
* debian/rules (clean): Clean more stuff here.
* Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead,
specify directly that the texi2html invocation produces that file.
* debian/rules (binary-indep): Find web files in slib subdir.
* debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'alist.txi')
-rw-r--r-- | alist.txi | 6 |
1 files changed, 6 insertions, 0 deletions
@@ -20,6 +20,7 @@ argument or @code{#f} if no key in the alist is @var{pred}-equal to the first argument. @end defun + @defun alist-inquirer pred Returns a procedure of 2 arguments, @var{alist} and @var{key}, which @@ -27,6 +28,7 @@ returns the value associated with @var{key} in @var{alist} or @code{#f} if @var{key} does not appear in @var{alist}. @end defun + @defun alist-associator pred Returns a procedure of 3 arguments, @var{alist}, @var{key}, and @@ -42,6 +44,7 @@ lost. This returned procedure may or may not have side effects on its @end lisp @end defun + @defun alist-remover pred Returns a procedure of 2 arguments, @var{alist} and @var{key}, which @@ -55,6 +58,7 @@ This returned procedure may or may not have side effects on its @end lisp @end defun + @defun alist-map proc alist Returns a new association list formed by mapping @var{proc} over the @@ -62,9 +66,11 @@ keys and values of @var{alist}. @var{proc} must be a function of 2 arguments which returns the new value part. @end defun + @defun alist-for-each proc alist Applies @var{proc} to each pair of keys and values of @var{alist}. @var{proc} must be a function of 2 arguments. The returned value is unspecified. @end defun + |