diff options
author | Steve Langasek <vorlon@debian.org> | 2005-01-10 08:53:33 +0000 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:30 -0800 |
commit | e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch) | |
tree | abbf06041619e445f9d0b772b0d58132009d8234 /alist.scm | |
parent | f559c149c83da84d0b1c285f0298c84aec564af9 (diff) | |
parent | 8466d8cfa486fb30d1755c4261b781135083787b (diff) | |
download | slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip |
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low
* Non-maintainer upload.
* Add guile.init.local for use within the build dir, since otherwise we
have an (earlier unnoticed) circular build-dep due to a difference
between scm and guile.
slib (3a1-4.1) unstable; urgency=low
* Non-maintainer upload.
* Build-depend on guile-1.6 instead of scm, since the new version of
scm is wedged in unstable (closes: #281809).
slib (3a1-4) unstable; urgency=low
* Also check for expected creation on slibcat. (Closes: #240096)
slib (3a1-3) unstable; urgency=low
* Also check for /usr/share/guile/1.6/slib before installing for guile
1.6. (Closes: #239267)
slib (3a1-2) unstable; urgency=low
* Add format.scm back into slib until gnucash stops using it.
* Call guile-1.6 new-catalog (Closes: #238231)
slib (3a1-1) unstable; urgency=low
* New upstream release
* Remove Info section from doc-base file (Closes: #186950)
* Remove period from end of description (linda, lintian)
* html gen fixed upstream (Closes: #111778)
slib (2d4-2) unstable; urgency=low
* Fix url for upstream source (Closes: #144981)
* Fix typo in slib.texi (enquque->enqueue) (Closes: #147475)
* Add build depends.
slib (2d4-1) unstable; urgency=low
* New upstream.
slib (2d3-1) unstable; urgency=low
* New upstream.
* Remove texi2html call in debian/rules. Now done upstream. Add make
html instead.
* Changes to rules and doc-base to conform to upstream html gen
* Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'alist.scm')
-rw-r--r-- | alist.scm | 55 |
1 files changed, 53 insertions, 2 deletions
@@ -1,5 +1,5 @@ ;;;"alist.scm", alist functions for Scheme. -;;;Copyright (c) 1992, 1993 Aubrey Jaffer +;;;Copyright (c) 1992, 1993, 2003 Aubrey Jaffer ; ;Permission to copy this software, to modify it, to redistribute it, ;to distribute modified versions, and to use it for any purpose is @@ -8,7 +8,7 @@ ;1. Any copy made of this software must include this copyright notice ;in full. ; -;2. I have made no warrantee or representation that the operation of +;2. I have made no warranty or representation that the operation of ;this software will be error-free, and I am under no obligation to ;provide any services, by way of maintenance, update, or otherwise. ; @@ -17,6 +17,23 @@ ;promotional, or sales literature without prior written consent in ;each case. +;;@code{(require 'alist)} +;;@ftindex alist +;; +;;Alist functions provide utilities for treating a list of key-value pairs +;;as an associative database. These functions take an equality predicate, +;;@var{pred}, as an argument. This predicate should be repeatable, +;;symmetric, and transitive. +;; +;;Alist functions can be used with a secondary index method such as hash +;;tables for improved performance. + +;;@body +;;Returns an @dfn{association function} (like @code{assq}, @code{assv}, or +;;@code{assoc}) corresponding to @var{pred}. The returned function +;;returns a key-value pair whose key is @code{pred}-equal to its first +;;argument or @code{#f} if no key in the alist is @var{pred}-equal to the +;;first argument. (define (predicate->asso pred) (cond ((eq? eq? pred) assq) ((eq? = pred) assv) @@ -30,12 +47,28 @@ ((pred key (caar al)) (car al)) (else (l (cdr al))))))))) +;;@body +;;Returns a procedure of 2 arguments, @var{alist} and @var{key}, which +;;returns the value associated with @var{key} in @var{alist} or @code{#f} if +;;@var{key} does not appear in @var{alist}. (define (alist-inquirer pred) (let ((assofun (predicate->asso pred))) (lambda (alist key) (let ((pair (assofun key alist))) (and pair (cdr pair)))))) +;;@body +;;Returns a procedure of 3 arguments, @var{alist}, @var{key}, and +;;@var{value}, which returns an alist with @var{key} and @var{value} +;;associated. Any previous value associated with @var{key} will be +;;lost. This returned procedure may or may not have side effects on its +;;@var{alist} argument. An example of correct usage is: +;; +;;@lisp +;;(define put (alist-associator string-ci=?)) +;;(define alist '()) +;;(set! alist (put alist "Foo" 9)) +;;@end lisp (define (alist-associator pred) (let ((assofun (predicate->asso pred))) (lambda (alist key val) @@ -44,6 +77,16 @@ alist) (else (cons (cons key val) alist))))))) +;;@body +;;Returns a procedure of 2 arguments, @var{alist} and @var{key}, which +;;returns an alist with an association whose @var{key} is key removed. +;;This returned procedure may or may not have side effects on its +;;@var{alist} argument. An example of correct usage is: +;; +;;@lisp +;;(define rem (alist-remover string-ci=?)) +;;(set! alist (rem alist "foo")) +;;@end lisp (define (alist-remover pred) (lambda (alist key) (cond ((null? alist) alist) @@ -58,9 +101,17 @@ (set-cdr! al (cddr al)) alist) (else (l (cdr al))))))))) +;;@body +;;Returns a new association list formed by mapping @var{proc} over the +;;keys and values of @var{alist}. @var{proc} must be a function of 2 +;;arguments which returns the new value part. (define (alist-map proc alist) (map (lambda (pair) (cons (car pair) (proc (car pair) (cdr pair)))) alist)) +;;@body +;;Applies @var{proc} to each pair of keys and values of @var{alist}. +;;@var{proc} must be a function of 2 arguments. The returned value is +;;unspecified. (define (alist-for-each proc alist) (for-each (lambda (pair) (proc (car pair) (cdr pair))) alist)) |