diff options
author | Thomas Bushnell <tb@debian.org> | 2007-12-28 15:56:00 -0800 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:38 -0800 |
commit | 967ca9f9b4c42630fb0feb1e5b9186266fa4d854 (patch) | |
tree | 8bbb64f76bd25bf5dc59c856167f46f67cfca2e9 /x.c | |
parent | 25fbaa7f8700665d5aea046956175a35035f7fd5 (diff) | |
parent | 710a97992705d67c3ded0d4b270c5978ce29b11f (diff) | |
download | scm-debian/5e4-1.tar.gz scm-debian/5e4-1.zip |
Import Debian changes 5e4-1debian/5e4-1
scm (5e4-1) unstable; urgency=low
* New upstream release.
* debian/control: Require at least version 3a5 of slib.
* debian/postrm: New file to remove /usr/lib/scm/implcat and
/usr/lib/scm/slibcat upon purge. (Closes: #455124). Thanks to Kumar
Appaiah for the fix.
* debian/control (Architecture): Add armel and armeb. (Closes: #408792).
* debian/rules (install): Don't use -s when installing. dh_strip should
be sufficient, and this should make the nostrip build option work.
(Closes: #438004).
* continue.h: Repeat change from 5e1-2.
* xgen.scm: Repeat change from 5e2-4.
* scm.1: Repeat change from 5e2-4.
* build.scm: Repeat change from 5e3-5.
Diffstat (limited to 'x.c')
-rw-r--r-- | x.c | 16 |
1 files changed, 8 insertions, 8 deletions
@@ -2317,7 +2317,7 @@ static int print_xwindow(exp, f, writing) { lputs(CLOSEDP(exp) ? "#<closed-X " : "#<X ", f); lputs((CAR(exp) & PXMP) ? "pixmap #x" : "window #x", f); - intprint((long) XWINDOW(exp), 16, f); + scm_intprint((long) XWINDOW(exp), 16, f); lputc('>', f); return 1; } @@ -2327,7 +2327,7 @@ static int print_xcursor(exp, f, writing) int writing; { lputs("#<X cursor #x", f); - intprint((long) XCURSOR(exp), 16, f); + scm_intprint((long) XCURSOR(exp), 16, f); lputc('>', f); return 1; } @@ -2347,7 +2347,7 @@ static int print_xcolormap(exp, f, writing) int writing; { lputs("#<X colormap ID #x", f); - intprint((long) XCOLORMAP(exp), 16, f); + scm_intprint((long) XCOLORMAP(exp), 16, f); lputc('>', f); return 1; } @@ -2357,8 +2357,8 @@ static int print_xgcontext(exp, f, writing) int writing; { lputs("#<X graphics context, ID #x", f); - /* intprint((long) GCONTEXT(exp)->gid, 16, f); skimu */ - intprint((long) XGContextFromGC(XGCONTEXT(exp)), 16, f); + /* scm_intprint((long) GCONTEXT(exp)->gid, 16, f); skimu */ + scm_intprint((long) XGContextFromGC(XGCONTEXT(exp)), 16, f); lputc('>', f); return 1; } @@ -2384,13 +2384,13 @@ static int print_xvisual(exp, f, writing) { XVisualInfo *xvi = XVISUALINFO(exp); lputs("#<X visual #x", f); - intprint((long) xvi->visualid, 16, f); + scm_intprint((long) xvi->visualid, 16, f); lputs(" ", f); lputs(xvisualclass2name(xvi->class), f); lputc(' ', f); - intprint((long) xvi->depth, 10, f); + scm_intprint((long) xvi->depth, 10, f); lputc('x', f); - intprint((long) xvi->colormap_size, 10, f); + scm_intprint((long) xvi->colormap_size, 10, f); lputc('>', f); return 1; } |